Versione Adunanza per LUBUNTU 16.04.2

Sulla guida ho trovato che per ubuntu 16.04 e derivate bisogna installare la versione 10315, mentre per ubuntu 16.10 e derivate, si deve installare la versione 11300.
Pochi giorni fa ho installato nativamente Lubuntu 16.04.2,che ha la particolarità di montare il Kernel 4.8 (che condivide con la versione 16.10) invece che il Kernel 4.4, tipico di ubuntu 16.04 (chi non dovesse fare l’upgrade di versione della 16.04, continuerà ad utilizzare il Kernel 4.4 e successivi aggiornamenti).
Insomma ubuntu 16.04.2 è un po’ un misto tra la versione 16.04 e la versione 16.10 e quindi, a questo punto, non so se io debba procedere con l’installazione di Adunanza 10315 o 11300.

Ciao @LorenzoMarco, non ti rimane che provarci, non credo che qualcuno abbia quella distro qui sul forum.
Prova e vedi quale fa al caso tuo. Se serve aiuto posta qui che se qualcuno ha tempo ti dà una mano.
Considera però che sia per la versione di Ubuntu 16.04 sia per la 16.10 molti pacchetti sono stati recuperati dalle 15 perché non più disponibili nei repository di ubuntu.

1 Like

Prima di tutto grazie per l’attenzione.
Purtroppo però credo di avere fatto la scelta sbagliata!
Ho deciso di fare finta di avere Ubuntu 16.10 e quindi ho proceduto all’installazione della versione 11300.
Il risultato è stato questo:

Si sono verificati degli errori nell'elaborazione:
 libpng12-0:amd64
 libpng12-0:i386
 libwxgtk2.8-0:amd64
 amule-adunanza
lorenzo@lorenzo-P5KC:~/amule-adunanza$ 

Ho provato a lanciare comunque adunanza ed è partita, anche se non è riuscita a collegarsi alla rete Kadu, ma questo credo sia un altro problema.
Il dramma invece è che adesso il S.O. denuncia problemi alle dipendenze e quindi si rifiuta di installare qualsiasi cosa e/o di procedere agli aggiornamenti.
Procedendo con il comando sudo apt upgrade -f, si ottiene:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
Calcolo dell'aggiornamento... Fatto
(omissis)
I seguenti pacchetti saranno aggiornati:
  libpng12-0
1 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
3 non completamente installati o rimossi.
È necessario scaricare 0 B/116 kB di archivi.
Dopo quest'operazione, verranno liberati 29,7 kB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 317768 file e directory attualmente installati.)
Preparativi per estrarre .../libpng12-0_1.2.54-1ubuntu1_amd64.deb...
Estrazione di libpng12-0:amd64 (1.2.54-1ubuntu1) su (1.2.51-0ubuntu3)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/libpng12-0/ANNOUNCE" (condiviso), diverso da altre istanze del pacchetto libpng12-0:amd64
Elaborazione dei trigger per libc-bin (2.23-0ubuntu7)...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
lorenzo@lorenzo-P5KC:~$ 

Ho provato a disinstallare Adunanza tramite la riga di comando con l’opzione -r, operazione andata a buon fine, ma il problema delle dipendenze è rimasto uguale a prima.
Ho fatto vari tentativi, anche un po’ random, tra cui quello di scaricare e sostituire l’archivio /libpng12-0_1.2.54-1ubuntu1_amd64.deb, ma senza risultati.
A questo punto avrei due domande:

  1. si tratta di un problema noto e quindi esiste una soluzione (ho cercato nel forum, ma non ho trovato nulla, su google c’ è una storia analoga con Mint, risoltasi con la formattazione e reinstallazione).
  2. se risolvo il problema delle dipendenze o reinstallo (gran scocciatura, ma non un dramma, dato che si tratta di installazione recente) e procedo con l’installazione della versione 10315, rischio lo stesso problema?
    Scusate per la scocciatura.

Per pulire togli i pacchetti appena inseriti con dpkg -r nomepacchetto.deb
e poi apt autoremove.

Se hai pazienza domani che dovrei avere tempo mi isntallo una vm con Lubuntu 16.04.2 e vediamo se riesco a deuggare il problema :wink:

La rimozione l’avevo fatta con dpkg -r *.deb una volta entrato nella cartella amule-adunanza, alias la cartella temporanea per installare adunanza.
Adesso ho provato con sudo apt autoremove e poi sudo apt autoremove -f
Il risultato è stato:

 lorenzo@lorenzo-P5KC:~$ sudo apt autoremove -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
The following additional packages will be installed:
  libpng12-0
I seguenti pacchetti saranno RIMOSSI:
  linux-headers-4.4.0-72 linux-headers-4.4.0-72-generic linux-headers-4.8.0-36
  linux-headers-4.8.0-36-generic linux-image-4.4.0-72-generic
  linux-image-4.8.0-36-generic linux-image-extra-4.4.0-72-generic
  linux-image-extra-4.8.0-36-generic
I seguenti pacchetti saranno aggiornati:
  libpng12-0
1 aggiornati, 0 installati, 8 da rimuovere e 0 non aggiornati.
3 non completamente installati o rimossi.
È necessario scaricare 0 B/116 kB di archivi.
Dopo quest'operazione, verranno liberati 612 MB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 317768 file e directory attualmente installati.)
Preparativi per estrarre .../libpng12-0_1.2.54-1ubuntu1_amd64.deb...
Estrazione di libpng12-0:amd64 (1.2.54-1ubuntu1) su (1.2.51-0ubuntu3)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/libpng12-0/ANNOUNCE" (condiviso), diverso da altre istanze del pacchetto libpng12-0:amd64
Elaborazione dei trigger per libc-bin (2.23-0ubuntu7)...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
lorenzo@lorenzo-P5KC:~$ 

Se riesci ad installare una macchina virtuale per provare, non so che dire se non GRAZIE!
Se però non dovessi riuscire, raso tutto e parto da zero.

@LorenzoMarco hai versione a 64 bit, giusto?

provato ora. La guida per ubuntu 16.04 funziona perfettamente.

Forse fai prima a piallare tutto e ripartire da una installazione pulita.

Grazie.
Si è la 64.
A questo punto, in cui sappiamo che la versione per 16.04 funziona per la 16.04.2, penso non sia più importante di tanto sapere cosa è successo e parto di pialla!

1 Like

esatto, inutile perderci la testa.

1 Like