[Risolto] Amule adunanza per Mint 18.2, ho preinstallato libwxgtk3.0-0v5 ma ho bisogno di libwxgtk2.8-0, che fare?

Ciao,
la mia nuova versione di mint lavora con ubuntu 16.04 e sto cercando di installare amule adunaza seguendo la guida del forum.
Tuttavia dopo l’installazione mi crea dei pacchetti danneggiati che mi bloccano gli aggiornamenti.
Emule adunanza si apre ma non si connette a kadu.
Comunque un problema alla volta, vorrei fare un’installazione di adunanza senza errori di file danneggiati, c’è qualche cosa che sbaglio?
A livello informativo, nei miei repository ho solo amule che se installato si apre senza problemi, connettendosi ad ed2k con id alto, ma non connettendosi a kad.
Grazie per l’aiuto

Che errori ti da quando apri amule da terminale?

Installando Amule non mi da nessun errore e solo che sono su fibra fastweb ed ho sempre usato amule adunanza.
Adesso ho disinstallato tutto e ho seguito piano piano la guida del forum.
Dopo aver scaricato i pacchetti di amule adunanza nel file zippato, per evitare problemi con i pacchetti ho verifcato di avere gia libwxbase2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb e libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64 installati quindi passo alla sola installazione di
amule-adunanza_2012.1+2.3.1~dfsg1-0ubuntu3_amd64
ma cercando di installarlo mi dice che la dipendenza con libwxgtk2.8-0 non può essere soddisfatta e non installa il pacchetto.
Ho verificato e nel mio sistema ho già installata la versione libwxgtk3.0-0v5 chiaramente successiva.
Come posso fare per installare amule adunanza senza fare casini con gli altri pacchetti?

Intendevo amule adunanza ovviamente, non amule normale :smiley:

Che comando dai con precisione ?

(ping @CoGe e @murra)

faccio doppio click sul pacchetto scaricato: amule-adunanza_2012.1+2.3.1~dfsg1-0ubuntu3_amd64.deb con l’installatore gdebi e che mi verifica le dipendenze prima di installarlo.
Vuoi che lo faccia da terminale?

No, dicevo che comando dai per installare libwxgtk2.8-0? Avevo capito che avevi provato a installarla manualmente da terminale…

Avendo verificato che ho già tra i pacchetti la versione successiva - libwxgtk3.0-0v5 - , dovrei disinstallarla prima di installare la 2.8.0 (correggimi se sbaglio)
ma se la disinstallo mi chiede di disinstallare anche una miriade di programmi che la utilizzano e non penso sia il caso.

No, non devi disistallare libwxgtk3.0-0v5, ma installare anche la versione libwxgtk2.8-0
In teoria non dovrebbe darti quell’errore, mi ricordo che quando usavo linux (ma anche su windows) era possibile installare varie versioni della stessa libreria se necessarie all’esecuzione di diversi programmi.

hai ragione !!
ho installato solo il pacchetto libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb
senza errori e dopo quello di adunanza.
Ho controllato e non ci sono errori tra i pacchetti
quindi l’errore che avevo avuto in precedenza derivava da libwxbase2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb che non ho installato ed emule adunanza funziona ugualmente
Grazie mille

Comunque, come regola generale, le lib non vanno mai disistallate manualmente. Quando aggiorni il sistema è lui stesso che fa il check e se ci sono librerie che non vengono più utilizzate ti chiede se vuoi disistallarle.

Aggiungo la segnalazione alla guida

1 Like

Questo argomento è stato automaticamente chiuso 5 giorni dopo l’ultima risposta. Non sono permesse altre risposte.