LineageOS su Xiaomi Redmi Note 4 - How to


#101

:meme_reaction_guy:


#102

Mi riferisco all’app Magisk Manager v5.8.2.apk. sono tentati di disinstallarla e reinstallarla per vedere se risolvo.

Ma è tutto un po’ strano, anche SafetyNet sembra dare problemi, se clicco sul controllo mi risponde “la risposta non è valida” :frowning:

(La versione 17.1 l’ho installata ieri per vedere se cambiava qualcosa) cosa che non è accaduta.)


In compenso (e questo credo interesserà anche @murra), ieri guardando nei moduli di Magisk ho scoperto che hanno implementato la ricarica veloce, ho installato il modulo e confermo che funziona (il telefono non è esploso :smiley: e mi è apparsa la scritta “ricarica veloce” ).

Va detto che non ho mai provato a fare una ricarica veloce prima di installare il modulo e quindi non so cosa sarebbe accaduto di diverso.


#103

Azz non saprei dirti. E’ un po’ che non seguo Magisk & Co. Magari questo fine settimana faccio una ricerca.


#104

Tranquillo Marko, scrivo solo per dovere di cronaca, io sono soddisfatto e mi accontento. Quest’inverno quando il freddo mi chiuderà agli arresti domiciliari magari avrò più tempo e voglia per fare qualche prova…

:thinking: in effetti ci sarebbe una cosa che non mi piace, la gestione delle notifiche, ma magari nei prossimi giorni apro un nuovo thread per spiegare meglio e chiedere consigli…

Notte!!!


#105

Io non ho problemi. Se non che da quando ho messo magisk il telefono lagga qualche secondo quando si riprende dallo schermo nero (credo dipenda dal fatto che ho messo magisk senza partire con il cellulare pulito, per pigrizia).

Hai usato la versione proposta nel OP di xda?


#106

ho usato la stable presa qui .

Io penso che sia la app Magisk Manager che mi da problemi, al momento ho la versione 5.7.0 (117) e ogni tanto mi esce l’avviso che è disponibile la versione 5.8.2 (128) ma se clicco su installa esegue il download ma poi fallisce l’installazione.

Il controllo di SafetyNet ti funziona?


#107

Anche io ho usato quella. Prova a rimuovere magisk e riflashare, come da info in quel topic.

L’unico problema che riscontro io da quando ho messo magisk è che quando sblocco il telefono con impronta digitale a volte ci mette più di 5 secondi a svegliarsi dallo schermo spento. Mistero. A te non succede?

Safety net è a posto

Anche magisk manager devi installarla da quel topic.

Hai installato tramite adb/fastboot o odin?


#108

Se non ricordo male (la vecchia…!), ho installato mettendo le app su microsim, poi con Twrp.

Non ho problemi col sensore di impronte tranne qualche volta dove tocco male o rapidamente, in qualche caso invece di farmi riprovare mi obbliga a digitare il codice (ma potrebbe anche essere una cosa voluta x sicurezza).

L’unico problema di base che riscontro è il non funzionamento del flash per le fotografie. Il led funziona come torcia ma non come flash


#109

Ma scusa @Goku una domanda stupida: hai abilitato il flash nella app che usi per le foto? nel caso la app fosse quella stock, hai provato a scaricarne altre per verificare se il problema si presenta anche con quelle?
EDIT:
Facendo una breve ricerca ho trovato qualcosa che, forse, può risolvere il problema


#110

Io uso la google camera (non ricordo quale, ne avevo provate diverse versioni) e il flash funziona bene, ma ogni tanto l’app crasha.


#111

La google camera non funziona su tutti i device giusto?


#112

Il problema è proprio lì, il flash non è abilitabile, è su off e non posso fare nulla per cambiare.

Grazie Marko, gli darò un’acchiata appena riesco. :+1:

Quando leggo google mi viene l’orticaria, ovviamente sono "costretto ad utilizzarla per le cose più comuni ma per il resto lascio.
Comunque faccio poche foto e col flash imho fanno comunque c4c4r3 e quindi anche senza sopravvivo :slight_smile:


#113

@Goku capisco che puoi sopravvivere anche senza Google, ma quel azz di flash bisogna farlo funzionare, è questione di principio :blush:
Sicuramente è un problema software, quindi niente di impossibile. Farò qualche altra ricerca appena ho tempo anche perché quel modello che hai tu è un gran telefono. Ovviamente se si può evitare di usare Google, meglio. :wink:


#114

@marko non diventar matto, appena ho qualche ora libera comincio provando la procedura del link di sopra.

OT (E’ che mi sono messo in testa di aggiornare e far ripartire l’odroid che è ferma da diversi mesi e il tempo è sempre troppo poco…)


#115

A me il flash funziona sempre sia con la gcam che senza. La google cam è molto bella e di fatto è un app fotocamera come le altre, con funzioni abbastanza belle, tra cui il famoso selfie sfuocato (l’ho installata per quello).

@gobne la google cam funziona su alcuni dispositivi, devono essere abbastanza potenti e avere hardware compatibile. Qui trovi tutti i port
https://www.celsoazevedo.com/files/android/google-camera/

Ma il sito è un bel casino… Ne ho provate decine, alcune crashano altre hanno solo alcune funzioni… Io stesso non ricordo quale ho installato alla fine :sweat_smile:

Comunque un buon punto di partenza, come sempre, è xda. Dai un’occhiata qua:

In generale un buon thread di riferimento per il nostro device è


(lo metto anche nel primo post)


#116

Grazie, leggerò sicuramente!
Ma tu hai cpu Media Tek o Snapdragon?


#117

Io ho la Snapdragon, dopo lo scatto ci mette 3-4 secondi a trasformare le foto con HDR+ e circa 7-8 secondi a trasformare le foto con sfondo sfumato.


#118

For BigG haters
(Qui ce ne stanno un paio mi sa)


#119

Scusa @murra non mi apre il link. Va alla pagina ma rimane in caricamento, ti risulta?


#120

a me funziona Marko