Installazione AmuleAdunanza Ubuntu 16.04&derivate (e Jessie)

ubuntu16.04
installazione
amule_adunanza

#1

Scrivo questa guida per facilitare l’installazione di amule adunanza su ubuntu 16.04 e derivate, dato che alcuni pacchetti non sono più presenti nei repository (dovrebbe funzionare anche per debian Jessie). Ringrazio @luivit per il suo contributo.


Installazione Amule-Adunanza su Ubuntu 16.04 (32 e 64 bit) e su distro simili (Debian Jessie e Derivate)

Innanzi tutto installare tramite apt alcune dipendenze:

sudo apt-get update
sudo apt-get install libcrypto++9v5 libupnp6

Scaricare i pacchetti mancanti dai repository (si possono reperire qui e sono:
libwxbase2.8-0 libwxgtk2.8 amule-adunanza)

Li allego per facilità

Scompattarli in una cartella qualsiasi e installarli con GDebi o da terminale con dpkg sudo dpkg -i *deb

NB: Alcune distro hanno già installato dei pacchetti più recenti. Non bisogna disinstallare i pacchetti più recenti (rischio di compromissione del s.o.), possono benissimo coesistere con i pacchetti presenti in questa guida necessari al mulo.


Se avete dubbi o problemi aprite un topic in #assistenza


Amule adunanza su ubuntu 16.10
Installazione adunanza su ubuntu 16.04
Download aMule AdunanzA per GNU/Linux e Mac OSX
Versione Adunanza per LUBUNTU 16.04.2
#7

per chi non ha facilità a effettuare ricerche : si potrebbe inserire anche un ZIP per gli I386?

THX


#8

Guida aggiornata coi pacchetti 32bit per @effemme8


#9

Ciao ho provato a seguire la tua guida (sono su debian jessie 8.6) ma ottengo delle dipendenze non soddisfatte : libcrypto++9v5 e per il pacchetto amule-adunanza e libjpeg8(>=8c) per il pacchetto libwxgtk2.8-0 e li mi blocco. Mi puoi aiutare per favore?
Grazie in anticipo


#10

Prova a lanciare
sudo apt install -f
per vedere se ti installa in automatico le dipendenze necessarie a dpkg.

Se non funzionasse, segui la guida per ubuntu 16.10 (non ho controllato, ma la 8.6 mi pare sia recente).


#11

Ciao e grazie per l’attenzione. Dunque premetto che sono passato a mint debian per me era troppo ostica e con poco supporto delle comunity (specialmente debianizzati)
Allora ho seguito la guida per la 16.10 (anche se mint 18 dovrebbe essere ancora su ubuntu 16.04) e funziona ma tanto per informarti ricevo queste risposte: [CODE]pino@pino-Mint-18 ~/amule-adunanza $ sudo dpkg -i *.deb
Selezionato il pacchetto amule-adunanza non precedentemente selezionato.
(Lettura del database… 238801 file e directory attualmente installati.)
Preparativi per estrarre amule-adunanza_2012.1+2.3.1~dfsg1-0ubuntu3_amd64.deb…
Estrazione di amule-adunanza (2012.1+2.3.1~dfsg1-0ubuntu3)…
dpkg: attenzione: retrocessione di libcrypto++9v5 dalla versione 5.6.1-9 alla 5.6.1-8
Preparativi per estrarre libcrypto++9v5_5.6.1-8_amd64.deb…
Estrazione di libcrypto++9v5 (5.6.1-8) su (5.6.1-9)…
dpkg: attenzione: retrocessione di libpng12-0:amd64 dalla versione 1.2.54-1ubuntu1 alla 1.2.51-0ubuntu3
Preparativi per estrarre libpng12-0_1.2.51-0ubuntu3_amd64.deb…
De-configurazione di libpng12-0:i386 (1.2.54-1ubuntu1)…
Estrazione di libpng12-0:amd64 (1.2.51-0ubuntu3) su (1.2.54-1ubuntu1)…
dpkg: attenzione: retrocessione di libupnp6 dalla versione 1:1.6.19+git20160116-1 alla 1:1.6.19+git20141001-1
Preparativi per estrarre libupnp6_1.6.19+git20141001-1_amd64.deb…
Estrazione di libupnp6 (1:1.6.19+git20141001-1) su (1:1.6.19+git20160116-1)…
Selezionato il pacchetto libwxbase2.8-0:amd64 non precedentemente selezionato.
Preparativi per estrarre libwxbase2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb…
Estrazione di libwxbase2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2)…
Selezionato il pacchetto libwxgtk2.8-0:amd64 non precedentemente selezionato.
Preparativi per estrarre libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb…
Estrazione di libwxgtk2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2)…
Configurazione di libcrypto++9v5 (5.6.1-8)…
dpkg: errore nell’elaborare il pacchetto libpng12-0:amd64 (–install):
il pacchetto libpng12-0:amd64 1.2.51-0ubuntu3 non può essere configurato perché libpng12-0:i386 ha una versione diversa (1.2.54-1ubuntu1)
dpkg: errore nell’elaborare il pacchetto libpng12-0:i386 (–install):
il pacchetto libpng12-0:i386 1.2.54-1ubuntu1 non può essere configurato perché libpng12-0:amd64 ha una versione diversa (1.2.51-0ubuntu3)
Configurazione di libupnp6 (1:1.6.19+git20141001-1)…
Configurazione di libwxbase2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2)…
dpkg: problemi con le dipendenze impediscono la configurazione di libwxgtk2.8-0:amd64:
libwxgtk2.8-0:amd64 dipende da libpng12-0 (>= 1.2.13-4); comunque:
Il pacchetto libpng12-0:amd64 non è ancora configurato.

dpkg: errore nell’elaborare il pacchetto libwxgtk2.8-0:amd64 (–install):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di amule-adunanza:
amule-adunanza dipende da libwxgtk2.8-0 (>= 2.8.12.1+dfsg2); comunque:
Il pacchetto libwxgtk2.8-0:amd64 non è ancora configurato.

dpkg: errore nell’elaborare il pacchetto amule-adunanza (–install):
problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per man-db (2.7.5-1)…
Elaborazione dei trigger per gnome-menus (3.13.3-6ubuntu3.1)…
Elaborazione dei trigger per desktop-file-utils (0.22-1ubuntu5)…
Elaborazione dei trigger per mime-support (3.59ubuntu1)…
Elaborazione dei trigger per libc-bin (2.23-0ubuntu4)…
Elaborazione dei trigger per doc-base (0.10.7)…
Elaborazione 1 file doc-base aggiunto…
Registrazione dei documenti con scrollkeeper…
Si sono verificati degli errori nell’elaborazione:
libpng12-0:amd64
libpng12-0:i386
libwxgtk2.8-0:amd64
amule-adunanza
pino@pino-Mint-18 ~/amule-adunanza $ sudo apt install -f
Lettura elenco dei pacchetti… Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato… Fatto
Correzione delle dipendenze… Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
cabextract gstreamer0.10-ffmpeg libavcodec-extra libhal1-flash libmspack0
libunshield0 oxideqt-codecs-extra unshield xplayer-plugins-extra
Usare “sudo apt autoremove” per rimuoverli.
The following additional packages will be installed:
libpng12-0
I seguenti pacchetti saranno aggiornati:
libpng12-0
1 aggiornati, 0 installati, 0 da rimuovere e 36 non aggiornati.
4 non completamente installati o rimossi.
È necessario scaricare 116 kB di archivi.
Dopo quest’operazione, verranno liberati 29,7 kB di spazio su disco.
Continuare? [S/n]
Scaricamento di:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 libpng12-0 amd64 1.2.54-1ubuntu1 [116 kB]
Recuperati 116 kB in 0s (372 kB/s)
(Lettura del database… 238872 file e directory attualmente installati.)
Preparativi per estrarre …/libpng12-0_1.2.54-1ubuntu1_amd64.deb…
Estrazione di libpng12-0:amd64 (1.2.54-1ubuntu1) su (1.2.51-0ubuntu3)…
dpkg: errore nell’elaborare l’archivio /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb (–unpack):
tentata sovrascrittura di “/usr/share/doc/libpng12-0/ANNOUNCE” (condiviso), diverso da altre istanze del pacchetto libpng12-0:amd64
dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Elaborazione dei trigger per libc-bin (2.23-0ubuntu4)…
Si sono verificati degli errori nell’elaborazione:
/var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
pino@pino-Mint-18 ~/amule-adunanza $ [/CODE]
Comunque Grazie!


#12

Scusa che versione di mint hai? lsb_release -a


#13

Grazie per la risposta, ho sia 17 rafaela che l’ultima 18. nella 17 ho appena reinstallato da synaptic e funziona ma ho dovuto fare le modifiche per errore 404 e i file server.met e nodes.dat in più sono sempre firewalled (due frecce gialle) nonostante abbia aperto le porte del router e non abbia firewall attivi…


#14


#15

Anche io ho lo stesso problema con ubuntu 16.04 con la differenza che mi ha bloccato Ubuntu software e non riesco più ad installare nulla neanche gli aggiornamenti. pensavo di formattare e installare di nuovo però essendo utente fastweb il problema rimane anche dopo come installo Adunanza senza danneggiare il sistema e come posso rimediare?
sudo apt-get install -f non risolve nulla grazie per ogni eventuale risposta


#16

cosa vuol dire che ti ha bloccato ubuntu software?
se apri un terminale e digiti
sudo apt update
cosa viene fuori?


#17
sudo apt update
[sudo] password di michele: 
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Trovato:2 http://archive.canonical.com/ubuntu xenial InRelease                 
Scaricamento di:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Trovato:4 http://repository.spotify.com stable InRelease                       
Trovato:5 http://it.archive.ubuntu.com/ubuntu xenial InRelease                 
Trovato:6 http://ppa.launchpad.net/pipelight/stable/ubuntu xenial InRelease    
Scaricamento di:7 http://dl.google.com/linux/chrome/deb stable Release [1.189 B]
Scaricamento di:8 http://cz.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Scaricamento di:9 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Scaricamento di:10 http://dl.google.com/linux/chrome/deb stable Release.gpg [916 B]
Scaricamento di:11 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1.472 B]
Scaricamento di:12 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [237 kB]
Scaricamento di:13 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Scaricamento di:14 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [228 kB]
Scaricamento di:15 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [499 kB]
Scaricamento di:16 http://cz.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1.201 kB]
Scaricamento di:17 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [101 kB]
Scaricamento di:18 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [54,3 kB]
Scaricamento di:19 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [42,4 kB]
Scaricamento di:20 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [103 kB]
Scaricamento di:21 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [92,9 kB]
Scaricamento di:22 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [53,9 kB]
Scaricamento di:23 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [488 kB]
Scaricamento di:24 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [32,1 kB]
Scaricamento di:25 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [37,0 kB]
Scaricamento di:26 http://it.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [200 kB]
Scaricamento di:27 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [288 kB]
Scaricamento di:28 http://it.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [190 kB]
Scaricamento di:29 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [448 kB]
Scaricamento di:30 http://cz.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1.196 kB]
Scaricamento di:31 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [436 kB]
Scaricamento di:32 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [171 kB]
Scaricamento di:33 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [159 kB]
Scaricamento di:34 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [188 kB]
Scaricamento di:35 http://cz.archive.ubuntu.com/ubuntu xenial/main Translation-it [441 kB]
Scaricamento di:36 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [2.520 B]
Scaricamento di:37 http://it.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3.328 B]
Scaricamento di:38 http://cz.archive.ubuntu.com/ubuntu xenial/main Translation-en [568 kB]
Scaricamento di:39 http://cz.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata [733 kB]
Scaricamento di:40 http://cz.archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [409 kB]
Recuperati 9.159 kB in 28s (322 kB/s)                                          
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
22 pacchetti possono essere aggiornati: eseguire "apt list --upgradable" per vederli.

#18

è da un po che non pubblico più post di questo genere e non mi ricordo come si fa a mettere il contenuto del terminale nel commento mi puoi aiutare?


#19

Usa semplicemente [code]codice[/code]


#21

grazie
mille ciao


#22

ora
sudo apt upgrade -y
così installi gli aggiornamenti


#23

Aggiunta alla guida segnalazione riguardo alle versioni dei pacchetti da installare @dax
ref [Risolto] Amule adunanza per Mint 18.2, ho preinstallato libwxgtk3.0-0v5 ma ho bisogno di libwxgtk2.8-0, che fare?