Installazione Amule Adunanza - da Ubuntu 16.10 a 17.10 & derivate

Ubuntu 16.10 e 17.04

Siccome nei repository di Debian, Ubuntu e derivate mancano molti pacchetti, per installare Amule Adunanza sulle Ubuntu 16.10 e 17.04 (e derivate) bisogna installare a mano i pacchetti necessari.

La seguente guida si riferisce ai sistemi a 64 e 32 bit.

Se vi servissero i pacchetti per altre architetture, fatemelo sapere che provvedo a recuperarli.

Preparazione del sistema:

Da terminale digitare:

sudo apt update
mkdir amule-adunanza
cd amule-adunanza

Scaricare i pacchetti relativi alla vostra architettura:

versione 64bit:
wget https://www.adunanza.net/download/amule-adunanza-16.10/amd64/amule-adunanza.zip
versione 32bit:
wget https://www.adunanza.net/download/amule-adunanza-16.10/x86/amule-adunanza.zip

Installazione pacchetti:

sudo apt install unzip
unzip amule-adunanza.zip
sudo dpkg -i *.deb

(se ci fossero dei messaggi che riportano problemi con l’installazione, digitare sudo apt install -f per installare automaticamente eventuali dipendenze non soddisfatte).

A questo punto abbiamo installato adunanza. Amule Adunanza si trova sotto menù -> internet -> Amule AdunanzA =)

Non ci resta che rimuovere i file di installazione

cd ..
rm -r amule-adunanza

NB: al primo avvio del client bisogna aggiornare correttamente l’url per scaricare il file nodes.dat:
Dal pannello “Networks” selezionare “Kad” quindi inserire al posto dell’url già presente questo: http://update.adunanza.net/adu_nodes.dat e premere il pulsante Cattura

Se avete problemi aprite un topic in #assistenza


-vecchi fix e versioni vecchie-

Mi raccomando dopo l’installazione di Amule Adunanza, eseguire questi due piccoli fix per far funzionare al meglio il muletto.

Fix server.met e nodes.dat su amule Adunanza (MAC e Linux)
Fix amule adunanza [404 - Errore (6)]


8 Likes

Salve Murra , come fare per installare Emule su Ubuntu 16.10 32 bit ???
Grazie .

@PaoloCAR ho aggiunto i pacchetti 32bit alla guida

2 Likes

Grazie mille !!!

@PaoloCAR mi puoi testare se funziona correttamente anche senza i due fix che ti ho messo sotto? Dovrebbero essere stati risolti.

Ho provato la guida, ma purtroppo sul mio debian 8.6 funziona solo in parte. Una volta immessi tutti i codici, amule adunanza risulta installato però cliccando sulla relativa icona non si apre; idem dal terminale. Inoltre, quando accedo al gestore pacchetti mi dice che ci sono tre file danneggiati; procedo così alla riparazione ma in tal caso amule adunanza scompare dai programmi installati.

ciao @Massimiliano_Bravi, puoi essere più preciso? Quali file risultano danneggiati? Senza info più dettagliate è difficile aiutarti.

Questa è la notifica che compare nel gestore dei pacchetti (grazie mille per l’aiuto):
amule-adunanza verrà rimosso
libcrypto++9v5 verrà rimosso
libwxgtk2.8-0 verrà rimosso
libcrypto++9 (versione 5.6.1-6+deb8u3) verrà installato

I file in realtà sono obsoleti non danneggiati, li rimuove perché il mulo non è installato correttamente e quindi identifica i pacchetti come non più necessari.

Dovresti provare a compilare dai sorgenti.

Oppure in alternativa installi il demone e la gui separati, usando i pacchetti per wheezy (dovrebbe funzionare).

Ciao scusa ma mi sono connesso al forum solo ora . Digito da un altro pc , appena posso connettermi da quello, se ti è ancora utile lo testo .

Grazie lo stesso, ho già testato e confermo che i due fix non sono più necessari, dato che abbiamo corretto il problema lato server.

Link della guida fixati per versione 64 bit.

(quelli per la 32 bit non li ho più. Nel caso servissero li cerchiamo).

1 Like

Link aggiornata con pacchetti versione 32bit.

Nota: la guida è testata e valida anche per le versioni di ubuntu e derivate 17.04.

Se ci fossero problemi aprite un topic in #assistenza

1 Like

Sistemata formattazione

3 messaggi sono stati fusi in un argomento esistente: Ubuntu 18.04 pc nuovo e non riesco a installare amule adunanza

Salve a tutti,
ho seguito la guida fino in fondo senza problemi.
Poi mi è apparsa la notifica di aggiornamento software che mi ha installato aMule Adunanza 2016.1b1
E’ normale?
Grazie

Non mi pare ci siano versioni aggiornate… @CoGe ne sai qualcosa? forse @mr_hyde ha compilato nuove versioni???

Senza dire nulla?Dubito alquanto.

Ho appena provato una nuova installazione, non ha aggiornato niente. @Luca_Trosce che versione di Linux hai?