Installazione amule-adunanza-2012.1-2.3.1 su jessie

linux

#21

Non ho mai lanciato come root (l’ho solo installato con sudo make install). Mentre per lanciare l’applicazione ho sempre fatto doppio click sull’icona. deselezionando l’opzione che dici i messaggi continuano ad apparire. Ti è crashato?
L’opzione --disable-ed2k cosa comporta?

EDIT
e se invece volessi installare la versione stabile?
In questo thread @skynet suggeriva di includere il file hpp dov’è definita la classe completa… Quindi come posso fare?


#22

io lancio amule dal terminale cosi’ vedo se da errori e almeno per un 15 minuto, deselezionando l’opzione, ha funzionato

l’opzione disable-ed2k serve a non compilare il programma ed2k che non serve ad amule per funzionare

la versione stabile NON è compilata con le Wx 3.02…
potresti compilarla tu, sai come fare :wink:


#23

A questo punto non capisco perchè da me, dopo qualche minuto, si chiude la beta (oltre al fatto che i messaggi di errore continuano ad apparire nonostante deseleziono l’opzione).
Per quanto riguarda la stabile ho già provato a compilarla con le wx3.02 ma mi da errore. Stando a quello che dice skynet devo includere il file hpp dov’è definita la classe completa. Il problema è che NON so proprio come fare…

P.S.
In ogni caso grazie per l’aiuto!!!


#24

neanch’io, pero forse possiamo provare un’altra via
Quell’errore è sulle Wx, questo l’abbiamo assodato, ebbene NON usiamole e l’errore sparisce!
Invece di usare amule usa l’accoppiata amuled + amuleGUI (cosa che io faccio da anni con il rasperry)

vuoi provarci? io sto sempre qua :occhiolino:


#25

Finalmente ho cambiato terminale. Ora sono su un i5! Ma i problemi persistono. Il mio sistema operativo è sempre Debian Jessie con Gnome.

Facciamo questo tentativo amuled + AmuleGui. Ma mi permette di sfruttare la rete fastweb?


#26

Si, se usi amuled AdunanzA


#27

Grazie per l’aiuto! Dove trovo la versione recente di Amuled Adunanza?


#28

@CoGe non riesco a trovare Amuled Adunanza… Trovo solo Amuled. Any Tips?


#29

In alto,nella sezione Download:

forum.adunanza.net/t/download-amule-adunanza-per-gnu-linux-e-mac-osx/1865


#30

Ho provato a compilare la versione aMule-AdunanzA-2012.1-2.3.1.
ho utilizzato: ./configure --enable-optimize --disable-debug --enable-amule-daemon --disable-ed2k --with-boost=/home/yoshi/Scaricati/boost_1_60_0

Quindi make:

yoshi@debian:~/Installati/aMule-AdunanzA-2012.1-2.3.1$ make
Compiling amuled.cpp
amuled.cpp: In member function ‘virtual int CDaemonAppTraits::WaitForChild(wxExecuteData&)’:
amuled.cpp:454:57: error: invalid use of incomplete type ‘class wxEndProcessData’
wxEndProcessData *endProcData = new wxEndProcessData();
^
In file included from amuled.cpp:26:0:
amule.h:564:29: error: forward declaration of ‘class wxEndProcessData’
typedef std::map<int, class wxEndProcessData *> EndProcessDataMap;
^
amuled.cpp:455:15: error: invalid use of incomplete type ‘class wxEndProcessData’
endProcData->pid = execData.pid;
^
In file included from amuled.cpp:26:0:
amule.h:564:29: error: forward declaration of ‘class wxEndProcessData’
typedef std::map<int, class wxEndProcessData *> EndProcessDataMap;
^
amuled.cpp:456:15: error: invalid use of incomplete type ‘class wxEndProcessData’
endProcData->process = execData.process;
^
In file included from amuled.cpp:26:0:
amule.h:564:29: error: forward declaration of ‘class wxEndProcessData’
typedef std::map<int, class wxEndProcessData > EndProcessDataMap;
^
amuled.cpp:457:15: error: invalid use of incomplete type ‘class wxEndProcessData’
endProcData->tag = 0;
^
In file included from amuled.cpp:26:0:
amule.h:564:29: error: forward declaration of ‘class wxEndProcessData’
typedef std::map<int, class wxEndProcessData > EndProcessDataMap;
^
amuled.cpp: In function ‘void OnSignalChildHandler(int, siginfo_t
, void
)’:
amuled.cpp:494:15: error: invalid use of incomplete type ‘class wxEndProcessData’
endProcData->exitcode = result != -1 && WIFEXITED(status) ?
^
In file included from amuled.cpp:26:0:
amule.h:564:29: error: forward declaration of ‘class wxEndProcessData’
typedef std::map<int, class wxEndProcessData *> EndProcessDataMap;
^
amuled.cpp:497:42: error: ‘wxHandleProcessTermination’ was not declared in this scope
wxHandleProcessTermination(endProcData);
^
Makefile:2493: set di istruzioni per l’obiettivo “amuled-amuled.o” non riuscito
make[3]: *** [amuled-amuled.o] Errore 1
Makefile:3381: set di istruzioni per l’obiettivo “all-recursive” non riuscito
make[2]: *** [all-recursive] Errore 1
Makefile:567: set di istruzioni per l’obiettivo “all-recursive” non riuscito
make[1]: *** [all-recursive] Errore 1
Makefile:471: set di istruzioni per l’obiettivo “all” non riuscito
make: *** [all] Errore 2


#31

Eco la soluzione al tuo problema
http://trac.wxwidgets.org/ticket/16325


#32

Grazie mille @skynet!!!
E’ sufficiente che creo quei tre file ed inserisco il codice che trovo su internet e li inserisco nella path:

/usr/lib/x86_64-linux-gnu/wx/

ovviamente creando anche la dir private?

yoshi@debian:/usr/lib/x86_64-linux-gnu/wx$ ls
config include

EDIT
cercando fra i file, ho notato che la pathname

wx/private/unix/pipestream.h

è diversa:

wx/unix/private/pipestream.h

mi date conferma?

Fonte: Github.com


#33

Purtroppo non funziona. Ho provato a compilare la versione “aMule-AdunanzA-2012.1-2.3.1”

Ecco l’errore:

Compiling amuled.cpp

In file included from /usr/include/wx-3.0/wx/unix/execute.h:19:0,
from amuled.cpp:73:
/usr/include/wx-3.0/wx/private/streamtempinput.h:24:5: error: stray ‘\302’ in program
wxWidgets/streamtempinput.h at master · wxWidgets/wxWidgets · GitHub
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:24:5: error: stray ‘\267’ in program
/usr/include/wx-3.0/wx/private/streamtempinput.h:24:5: error: stray ‘\302’ in program
/usr/include/wx-3.0/wx/private/streamtempinput.h:24:5: error: stray ‘\267’ in program
In file included from /usr/include/wx-3.0/wx/unix/execute.h:19:0,
from amuled.cpp:73:
/usr/include/wx-3.0/wx/private/streamtempinput.h:114:7: error: missing terminating ’ character


^
In file included from /usr/include/wx-3.0/wx/unix/execute.h:19:0,
from amuled.cpp:73:
/usr/include/wx-3.0/wx/private/streamtempinput.h:786:22: error: too many decimal points in number
wxPy-3.0.0
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:875:23: error: invalid suffix “_1_5” on integer constant
xrced-0_1_5-3
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:895:26: error: invalid suffix “_1b3” on integer constant
wxPython-2_1b3
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:905:26: error: invalid suffix “_1b1” on integer constant
wxPython-2_1b1
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:915:26: error: invalid suffix “_5_4” on integer constant
wxPython-0_5_4
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:925:26: error: invalid suffix “_5_3” on integer constant
wxPython-0_5_3
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1565:22: error: too many decimal points in number
wxPy-2.8.4.2
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1625:19: error: too many decimal points in number
v3.0.2
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1635:19: error: too many decimal points in number
v3.0.1
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1645:19: error: too many decimal points in number
v3.0.0
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1655:19: error: too many decimal points in number
v3.0.0-rc2
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1665:19: error: too many decimal points in number
v3.0.0-rc1
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1675:19: error: too many decimal points in number
v2.9.5
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1685:19: error: too many decimal points in number
v2.9.4
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1695:19: error: too many decimal points in number
v2.9.4-rc1
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1705:19: error: too many decimal points in number
v2.9.3
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1715:19: error: too many decimal points in number
v2.9.3-rc1
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1725:19: error: too many decimal points in number
v2.9.2
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1735:19: error: too many decimal points in number
v2.9.1
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1745:19: error: too many decimal points in number
v2.9.0
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1755:19: error: too many decimal points in number
v2.8.12
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1765:19: error: too many decimal points in number
v2.8.11
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1775:19: error: too many decimal points in number
v2.8.10
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1785:19: error: too many decimal points in number
v2.8.9
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1795:19: error: too many decimal points in number
v2.8.8
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1805:19: error: too many decimal points in number
v2.8.7
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1815:19: error: too many decimal points in number
v2.8.6
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1825:19: error: too many decimal points in number
v2.8.5
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1835:19: error: too many decimal points in number
v2.8.4
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1845:19: error: too many decimal points in number
v2.8.4-rc2
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1855:19: error: too many decimal points in number
v2.8.3
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1865:19: error: too many decimal points in number
v2.8.2
^
In file included from /usr/include/wx-3.0/wx/unix/execute.h:19:0,
from amuled.cpp:73:
/usr/include/wx-3.0/wx/private/streamtempinput.h:1984:70: error: stray ‘#’ in program
#ifndef _WX_PRIVATE_STREAMTEMPINPUT_H
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1988:70: error: stray ‘#’ in program
#define _WX_PRIVATE_STREAMTEMPINPUT_H
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:1997:70: error: stray ‘#’ in program
#include wx/private/pipestream.h
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:2489:71: error: stray ‘#’ in program
#endif // _WX_PRIVATE_STREAMTEMPINPUT_H
^
/usr/include/wx-3.0/wx/private/streamtempinput.h:2499:3: error: missing terminating ’ character

^
In file included from /usr/include/wx-3.0/wx/unix/execute.h:19:0,
from amuled.cpp:73:
/usr/include/wx-3.0/wx/private/streamtempinput.h:5:1: error: expected unqualified-id before ‘<’ token

^
In file included from /usr/include/wx-3.0/wx/unix/execute.h:19:0,
from amuled.cpp:73:
/usr/include/wx-3.0/wx/private/streamtempinput.h:1894:3: error: expected unqualified-id before ‘<’ token

^ In file included from /usr/include/wx-3.0/wx/unix/execute.h:19:0, from amuled.cpp:73: /usr/include/wx-3.0/wx/private/streamtempinput.h:1997:151: error: expected unqualified-id before ‘<’ token #include "wx/private/pipestream.h" ^ /usr/include/wx-3.0/wx/private/streamtempinput.h:1997:208: error: expected unqualified-id before ‘<’ token #include "wx/private/pipestream.h" ^ Makefile:2497: set di istruzioni per l'obiettivo "amuled-amuled.o" non riuscito make[3]: *** [amuled-amuled.o] Errore 1 Makefile:3385: set di istruzioni per l'obiettivo "all-recursive" non riuscito make[2]: *** [all-recursive] Errore 1 Makefile:569: set di istruzioni per l'obiettivo "all-recursive" non riuscito make[1]: *** [all-recursive] Errore 1 Makefile:473: set di istruzioni per l'obiettivo "all" non riuscito make: *** [all] Errore 2

Ho provato anche la Moonriver ma continua a chiudersi… Uff


#34

@yoshi ma hai provato a installare semplicemente la versione stabile? così:

sudo apt-get install amule-adunanza

(prima rimuovi le vecchie installazioni con sudo apt-get remove --purge amule*)


#35

yoshi@debian:~$ sudo apt-get install amule-adunanza
Lettura elenco dei pacchetti… Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato… Fatto
E: Impossibile trovare il pacchetto amule-adunanza


#36

Nessun suggerimento?!? :confounded::cry:


#37

@yoshi mi dispiace non poterti aituare di più, ma io non ho ancora messo jessie. Con wheezy il mulo non dà problemi.


#38

Forse faccio un rollback a wheezy… mi trovavo anche meglio… Ma possibile che non si trova una cavolo di soluzione!!! Che fregatura :disappointed:


#39

Anche io l’ho fatto, ho avuto troppi problemi ancora con jessie.


#40

Ciao Yoshi. Se hai un pò di pazienza sto mettendo su un pc con jessie e magari si riesce a combinare qualcosa. Da quel che ho capito (e di linux conosco solo il fatto che esiste) servono le wxwidget 2.8 ma jessie installa di default le 3.0. Le 2.8 avevano esponevano una classe privata che amule faceva riferimento. Nelle 3.0 giustamente l’hanno nascosta da cui il tuo errore.
Vediamo se riesco trovare una soluzione.

Edit: Mi serve il link da dove hai scaricato amule, così provo con i tuoi stessi dati.