Impostazioni post installazione: quali server e quale nodes.dat? E altro ancora :)

Il file che cerca amule evidentemente è fisso e appartiene al portale che non tornerà in tempi brevi e non è sul nuovo server quindi non possiamo farci nulla.

I problemi dei servers e dei nodi si risolve facilmente scaricando i file met e incollandoli nella cartella adunanza sotto library. Probabilmente il vero problema è che i files principali sono corrotti e mettendoglieli recenti va tutto a posto e smette di scaricare in modo ciclico le liste nodi e servers.
Basta chiudere l’app copiarli nella cartella config sovrascrivendo i precedenti e riavviare.
Non sono invece ancora riuscito a risolvere il problema della adunanza.conf.download’, line 1: ‘=’ expected.
Ogni sessanta secondi scarica un file e poi da errore nel log di aule adunanza.
Avete qualche idea?

nessuno del team ha segnalato corruzione di file, c’è solo un problema di puntamento al dominio www.adunnza.net/files che non esiste piu’ ma è fisso in amule.

Mi scuso allora per l’errata presunzione, però vi chiedo se è possibile fermare il sistema che ogni 60ss fa partire un processo di download del file verso, come si è detto un indirizzo inesistente.
Ho notato che nella cartella c’è un file adunanza.conf. Addirittura c’è anche una versione backup con estenzione .bak (con righe di comando totalmetne diverse).
La cosa è fastidiosa… si può vivere, ma disturba e poi son curioso :wink:

Io anche ho gli stessi tuoi problemi mi da sempre quell’errore e non riesco a trovare nessun server…

buon giorno,
sono incappato nella vostra discussione perché anch’io avevo il problema dello scaricamento dei nodi ogni 60 secondì. Semmai avete già risolto, ma provo a condividere la mia soluzione:
ho risolto modificando a mano il file amule.conf, la riga:

KadNodesUrl=" http://www.adunanza.net/files/emule/adu_nodes.dat"

in

KadNodesUrl="http://www.adunanza.net/files/emule/adu_nodes.dat"

ho tolto cioè lo spazio prima delle prime ". Consiglio di fare una copia di sicurezza di tale file prima di modificarlo.
Saluti a tutti

Enrico

1 Like

Ma www.adunanza.net non è online come diceva @Hammon qualche post più sopra.
Dubito quindi che scarichi un file nodes nuovo, semplicemente elimina l’errore che rileva il mulo nella sintassi del link.

Bisognerebbe provare a usare il nodes di emule, cambiando la stringa da te citata in "http://update.adunanza.net/nodes.dat"
se non erro.

Occorrono verifiche.

No @dax credo di aver rediretto al nodes giusto, se quello che ha suggerito funziona fatelo :slight_smile:

1 Like

Bueno a sapersi. Grazie

probabilmente hai ragione, comunque elimina il fastidioso errore, che tra l’altro a me impallava il pc. adesso sembra funzioni tutto

A me non va lo stesso, prima di tutto non c’era nessuno spazio prima ne virgolette mi riporta semplicemente
KadNodesUrl=http://www.adunanza.net/files/emule/adu_nodes.dat

che ho cambiato con http://update.adunanza.net/nodes.dat

ma il problema persiste e l’errore che mi segnala è adunanza.conf.download

Grazie

non so che dire, con me ha funzionato, l’unico consiglio che mi sento di dare è di provare ad aprire adunanza.conf.download (previa copia di sicurezza) con un editor e vedere se ci sono imperfezioni, tipo spazi inopportuni o cose del genere e correggerle. Se hai un altro pc con adunanza prova a confrontare i 2 files.
in bocca al lupo

Confermo che anche il mio coniglietto impazzito scarica a raffica senza successo. ho cambiato come suggerito pero non funziona.
Per di piu dopo un po che gira amule si freeza con un errore che si vede solo da terminale:



E’ stato riscontrato un errore che ha causato il crash di aMule AdunanzA.
Ricordate che il team di aMule ufficiale NON supporta in alcun modo
AdunanzA, quindi NON spedite loro il seg. log.
Il log potrebbe essere utile solo agli sviluppatori di aMule AdunanzA
accompagnato da informazioni quali:

  • la versione di Adunanza attuale ovvero
    aMule 2.3.1 - AdunanzA 2012.1;
  • il sistema operativo (Linux/MacOS/FreeBSD/Windows varie ed eventuali),
    la distribuzione e la versione;
  • la descrizione (il piu’ dettagliata possibile) delle azioni che hanno portato
    al crash.
    Sappiate comunque che dump originati da eseguibili compilati SENZA le opzioni
    di debug o CON OTTIMIZZAZIONI abilitate NON saranno presi in considerazione
    (sono praticamente inutili).
    Se possibile provate a generare un vero backtrace come descritto in:
    http://wiki.amule.org/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMuleAdunanzA MOD based on aMule 2.3.1 compiled with wxGTK2 v2.8.12 AdunanzA 2012.1
Running on: Linux 3.16.0-38-generic x86_64

Per sicurezza ho anche fatto una macchina pulita nuova con solo amule, dopo un giorno di utilizzo è apparso anche qui il freeze. Ovviamente accade sempre 10min dopo che esco di casa e lascio il pc acceso in scarico :smile:

Il freeze o il crash? Sono cose distinte, e se si freeza solamente è molto probabile che sia per impostazioni errate (valori troppo alti in upload e download).

Amule si freeza, nel log appare il messaggio di crash che ho indicato.
Non sono impostazioni errate perche sul mio pcfisso che uso per scaricare da anni (2012) ha cominciato a dare problemi solo negli ultimi due mesi (le impostazioni sono sempre quelle da anni). Ormai non lo lascio piu acceso perchè va sempre in errore.
Sottolineo che non faccio mai upgrade a questa macchina (mint-linux … macchina che vince non si cambia :slight_smile:

Per curiosità ho messo su un portatile l’ultimo mint per valutare upgrade e verificare funzionamento amule ma alla lunga si blocca con stesso problema

Fa un test di velocità a mulo chiuso e imposta i valorri di up e down all’80% della tua velocità reale

si si solitamente lascio 60% rispetto al massimo di up e 50% in down

Non posso controllare perchè ho recentemente formattato il portatile dove risiedeva la partizione di debian. Sulle Preferenze ci sono anche le fonti massime (Limite massimo) e i limiti di connessione (Connessioni Massime)? Hai provato a ridurli?

Comunque se amule ti è sempre funzionato e la tua linea è stabile probabilmente hai cambiato qualche impostazione della macchina. Possibile che tu abbia attivato qualche risparmio energetico (magari sulla scheda di rete) visto che il freeze/crash capita sempre quando non sei al pc?

Non è attivo il risparmio energetico su quel pc. Comuqnue ora che sto smanettando lasciando sotto attivo amule si incricca spesso.

io lancio amule da script sh visto che ogni tanto va in segmentation fault (Sempre dato su tutte le installazioni che ho fatto dal 2007).

while /bin/true; do /usr/bin/amule; date; done

ora su stessa console mi ritrovo il msg di crash. Come detto fino meta/fine ottobre 2015 non mi era mai uscito. Pensavo fosse colpa del mio pc, ma ora me lo da pure su questo “pulito”. A nessuno capita?

Sto cominciando a farmi lo script che quando becca nel log un crash riavvia tutto :smile:

Script modiicati e completati. Ne ho fatto uno simile al precedente che scrive in un file di log tutti i messaggi della console ed un altro schedulato in crontab ogni minuto che controlla la presenza del messaggio di crash bloccante (che non fa chiudere e riaprire amule in autonomia e visualizza il messaggio che ho postato prima) e se la trova uccide amule. Uccidendo l’altro script in ciclo continuo lo fa ripartire.
Non sarà elegante ma funziona. Ho lasciato il pc acceso tutta notte ed è andato tranquillo.
L’elenco dei crash con forzato riavvio pero è molto alta.

Rilevato crash - riavvio mar 8 dic 2015, 07.54.39, CET

Rilevato crash - riavvio mar 8 dic 2015, 07.59.15, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.02.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.06.19, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.09.40, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.16.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.20.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.24.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.26.52, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.32.02, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.35.53, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.40.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.46.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.52.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 08.58.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.02.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.05.27, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.10.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.21.08, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.26.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.32.02, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.36.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.40.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.42.38, CET

Rilevato crash - riavvio mar 8 dic 2015, 09.50.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.02.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.06.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.12.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.18.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.22.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.26.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.30.02, CET

Rilevato crash - riavvio mar 8 dic 2015, 10.36.01, CET

Rilevato crash - riavvio mar 8 dic 2015, 11.22.01, CET

per rimanere nel tema del post iniziale i file nodes.dat e servers.met li ho presi dal mio vecchio pc che usavo per scaricare perchè quelli sul sito files-adunanza non mi parevano ok. se a qualcuno servono ve li posso passare