Help risoluzione del mio sito non raggiungibile


#1

Allora ho un problema strano.
Premetto che il sito è raggiungibile da altri ip e provider.

Gestisco il sito http://www.myplay.it e http://www.strangebeat.it

Ora fino a ieri tutto bene (e non ho toccato nulla del router) poi ad un certo punto, anche facendo un bel tracert non riesco a raggiungere i 2 domini,
ma SOLO con il mio ip statico in quanto se lo faccio da altra connessione (3G o dalla connesisone di mia sorella) il sito va che è una meraviglia.

Ho provato a flusshare la cache dns.
Avete soluzioni o idee di cosa possa essere successo?


#2

Che DNS usi sul router?


#3

Ciao
uso google.

8.8.8.8
8.8.4.4


#4

Anche sul pc? E che provider hai che non mi ricordo?


#5

Si anche su pc. Ho provato anche da mac e da cell (via wi fi).

provider, quello arancione… fastweb :slight_smile:


#6

Non hai accesso al server che hosta i siti?
Dai log dovresti capire se il problema è il tuo ip o meno.

Ping @CoGe e @murra


#7

Il problema è che anche il pannello di controllo, che risiede su un altro server risulta irraggiungibile.
Ho nel frattempo sentito fastweb e mi dicono di aprire una segnalazione per irraggiungimento siti.

Fatto particolare è che se pingo ad esempio www.myplay.it ricevo i pacchetti tranquillamente
Se invece vado di http o tracert non riesco a raggiungerlo.

Ho provato anche il comando netsh reset winsock, ma senza risultati


#8

Riesci a pingare, ma non ad accedere al sito?
Cosa mi dici di ssh/ftp o altri servizi, riesci ad usarli?

edit: hai fail2ban installato? non è che ti sei autobannato per sbaglio?


#9

Si esatto pingo, ma ne con tracert, ftp, ssh accedo all’host.

Se hai idee…


#10

che errore hai con ssh?

spiega meglio, come se ti ascoltasse un bimbo di 6 anni.


#11

Allora rettifico,
sia il sito che il pannello di controllo risiedono sullo stesso server
con il medesimo IP.

Non ho provato con ssh.

Come vedete al ping risponde perfettamente

PING myplay.it (77.223.16.131): 56 data bytes
64 bytes from 77.223.16.131: icmp_seq=0 ttl=53 time=17.989 ms
64 bytes from 77.223.16.131: icmp_seq=1 ttl=53 time=17.787 ms
64 bytes from 77.223.16.131: icmp_seq=2 ttl=53 time=18.401 ms
64 bytes from 77.223.16.131: icmp_seq=3 ttl=53 time=17.356 ms
64 bytes from 77.223.16.131: icmp_seq=4 ttl=53 time=17.361 ms
64 bytes from 77.223.16.131: icmp_seq=5 ttl=53 time=19.067 ms
64 bytes from 77.223.16.131: icmp_seq=6 ttl=53 time=17.346 ms

traceroute (arriva ad Aruba e si perde?)

traceroute to myplay.it (77.223.16.131), 64 hops max, 52 byte packets
1 192.168.1.254 (192.168.1.254) 4.516 ms 4.026 ms 1.247 ms
2 2.229.192.1 (2.229.192.1) 5.665 ms 5.992 ms 5.442 ms
3 10.0.33.158 (10.0.33.158) 7.022 ms
10.0.33.134 (10.0.33.134) 18.714 ms
10.0.33.142 (10.0.33.142) 9.449 ms
4 10.250.113.194 (10.250.113.194) 6.724 ms 11.088 ms 6.428 ms
5 10.0.0.45 (10.0.0.45) 6.803 ms
10.0.0.205 (10.0.0.205) 7.525 ms
10.0.0.45 (10.0.0.45) 7.434 ms
6 10.254.2.178 (10.254.2.178) 9.640 ms
10.254.2.69 (10.254.2.69) 7.746 ms 9.430 ms
7 62-101-124-129.fastres.net (62.101.124.129) 7.201 ms 8.178 ms
62-101-124-125.fastres.net (62.101.124.125) 7.714 ms
8 93-63-100-50.ip27.fastwebnet.it (93.63.100.50) 7.723 ms
62-101-124-129.fastres.net (62.101.124.129) 7.526 ms
62-101-124-125.fastres.net (62.101.124.125) 8.082 ms
9 93-63-100-50.ip27.fastwebnet.it (93.63.100.50) 8.498 ms
93-63-100-46.ip27.fastwebnet.it (93.63.100.46) 8.193 ms
93-63-100-49.ip27.fastwebnet.it (93.63.100.49) 56.778 ms
10 aruba.mix-it.net (217.29.66.90) 7.680 ms 8.353 ms
93-63-100-45.ip27.fastwebnet.it (93.63.100.45) 8.176 ms
11 62.149.191.51 (62.149.191.51) 14.518 ms 16.911 ms 14.074 ms
12 62.149.185.43 (62.149.185.43) 14.347 ms
62.149.191.51 (62.149.191.51) 18.115 ms 18.809 ms
13 62.149.185.44 (62.149.185.44) 14.212 ms
62.149.185.43 (62.149.185.43) 17.304 ms
host244-27-37-46.serverdedicati.aruba.it (46.37.27.244) 18.645 ms
14 host244-27-37-46.serverdedicati.aruba.it (46.37.27.244) 15.026 ms 15.386 ms *
15 * * *
16 * * *
17 * * *


#12

i tuoi domini risultano pingabili e raggiungibili
il tuo server non risponde all’ssh

il server è tuo o hai acquistato solo spazio web?


#13

No il server non è mio sono in hosting.
Ho provato ad accedere con un proxy e il sito è raggiungibile.

A sto punto devo capire se Aruba può avere bannato il mio ip,
anche se mi sembra strano che riesco a pingarlo, ma non a risolvere http…


#14

Ok, vorrei informare tutti che il problema si è risolto.
Colpa di ■■■■■■■ hacker che per una settimana hanno vioalto il sito con sql injection prendendone il controllo e mandando email di spam

Ora tutto a posto e mi hanno sbannato l’ip dal firewall


#15

Come caxxo hanno fatto sql injection???
Ma che provider stai usando? Aruba?
Fossi in te scapperei a gambe levate, vuol dire che per la sicurezza lato server non ci si può fidare.
A meno che tu ovviamente non abbia creato una falla sul tuo sito a livello di codice, ma anche in quel caso il server (a meno che non ci abbia messo le mani tu sbagliando configurazione) dovrebbe essere impostato per prevenire attacchi del genere.


#16

Purtroppo php e sql sono bucabili, il problema non è (sempre) il server in sé, ma i componenti installati sopra (php e sql sono spesso sfruttati dagli attaccanti). Se c’è ad esempio una pagina che permette delle query al db tramite php, si possono fare delle injection interrogando sql per sapere i vari dati all’interno (users, password ad esempio): per esempio, le pagine tipo qualcosa.php? sono spesso iniettabili.

Sta a chi inserisce un servizio php assicurarsi che sia sicuro, con i permessi corretti e privilegi minimi. Per quanto non mi piaccia Aruba, sono convinto che lato server abbiano degli standard di sicurezza accettabili.

Di vulnerabilità ce ne sono tantissime, esistono persino siti per esercitarsi a, diciamo, trovarle: http://www.testphp.vulnweb.com/


#17

Non sono bucabili così facilmente, o quantomeno puoi fare in modo di non subire sql injection e ancor peggio code injection se prendi le dovute precauzioni.
Certo che se non proteggi adeguatamente il server e se si usano script a cavolo, senza sapere cosa fanno e come agiscono (e non ci sai mettere mano) un sql injection è il minimo che ti può succedere.

Abbiamo passato giorni per configurare gli script sul mio sito (e il server) in modo da non poter subire attacchi di questo tipo, specialmente adesso che abbiamo aggiunto la funzione “Invia file” (e ancora non abbiamo finito…).

Qualsiasi sito che ha una newsletter o un invio mail se non è adeguatamente protetto è suscettibile di attacchi di questo tipo

Te lo possono proteggere anche con una bomba atomica, ma se come minimo non cambi URL e non gli modifichi i dati di accesso il primo bimbominkia che passa è capace di fare disastri inenarrabili


#18

Sono d’accordo, tenere sempre un occhio, anzi due, riguardo a ciò che si mette, e come sempre, RTFM!


#19

Bho forse colpa mia è dal 2005 che avevo scritto il codice php e non l’ho mai toccato,
ma sino ad una settimana fa, nessuno ha mai rotto le palle.
Nessun plug-in o codice strano, puro php scritto a mano con textpad :slight_smile:

Vabbè, ora trasferisco tutto sotto wordpress e via.


#20

Non è che worpress sia meglio in quanto a sicurezza…ma vabbè.
Conviene ogni tanto che monitori sito e server per vedere lo stato di sicurezza…specie se hai degli script del 2005 (ovvero 12 anni fa :scream:)