Continui crash di Emule Adunanza


#1

Rispondi alle domande del questionario se cerchi assistenza!

Per utenti Windows:

  1. Versione eMule AdunanzA utilizzata (es. 3.16, 3.18): 3.18
  2. Risultato Test Porte: superato
  3. Colore delle frecce sul MappaMondo in basso a destra: verdi
  4. Prima terzina dell’indirizzo IP rilevato sul Test Porte o se il Test Porte dovesse essere offline QUI (es. 100.XYZ., 10.XYZ, 2.23X): 93.46.XXX.XXX
  5. Sistema operativo (es. Windows XP, Vista, Win7 …): Windows 10
  6. Antivirus (Nome e Versione: es. Antivir PE): AVAST FREE ANTIVIRUS
  7. Firewall (Nome e Versione: es. Zone Alarm 8.0.100 ): Windows Defender
  8. Tipo di connessione (es. adsl, fibra, aziendale, alice adsl, wi-fi o cavo): Wi-FI
  9. Marca e Modello dell’hag/router a cui sei collegato (es. Technicolor TG788vn): Technicolor TG789vac v2
  10. L’ indirizzo IP rilasciato dal router al PC (es. 192.168.1.129, 10.110.1.100) che trovate QUI : 192.168.1.68
  11. Eventuali altri dati reputati utili (altro hardware o software rilevante):
  12. Breve descrizione del problema: Ciao a tutti, vi scrivo perché ho un problema; quando metto a scaricare un file (sto scaricando ad esempio un file solo, di circa 11GB) parte il download ma poi emule va in crash. A volte non riesco più a fare niente, non si riesce a cliccare da nessuna parte ma vedo che il download procede (cambia il completamento, anche se non la velocità di download). Ad esempio prima stavo scaricando a oltre 3MB ed era arrivato ad oltre il 20%. Quando è in questa situazione o lo chiudo forzatamente da “gestione attività” oppure lo lascio andare ma poi dopo un po’ quando torno a pc emule non è più in esecuzione. Lo riapro ed il file che stavo scaricando è o allo 0% oppure stamattina l’ho trovato al 13%. Così facendo non riesco mai a finire il file. Ho provato le seguenti azioni: 1) cancellare i permessi dal firewall di windows e ridarli; 2) impostare modalità compatibilità Windows Vista SP2; 3) rifare il wizard. Dallo speed test mi risulta Download 49592 Kbps e Upload 19384 Kbps (dovrei avere fibra 100MB) ed ho settato la capacità down12800 up1280 mentre i Limiti di traffico down4960 up1280. Sbaglio qualcosa?
    Chiedo scusa se è un argomento già trattato ma non sono stato in grado di trovare una soluzione. Grazie a chi mi saprà aiutare e buone feste a tutti!

(Quando risolverete i vostri problemi cliccate il tasto “Soluzione” sul post dell’utente che vi ha indicato la soluzione.)

======================================================================
Per utenti LINUX, rispondere a queste domande Questionario di assistenza per Emule ed Amule Adunanza
Per utenti MAC, rispondere a queste domande Questionario di assistenza per Emule ed Amule Adunanza


#2

Prova ad abbassare ulteriormente il limite di download, impostalo sotto i 4000


#3

Già provato, down a 700 e up a 170, dopo una decina di minuti si è bloccato, sembra continui a scaricare (la % avanza) ma non riesco a fare nulla. La velocità nel momento in cui si è bloccato era 1.26MB/s


#4

Scarichi su un Hd esterno?


#5

No, nssun hd esterno


#6

Stesso identico problema: appena parte il download di un certo file (più di 70 GB, quindi sostanzioso) emule si freeza, l’utilizzo della CPU dedicato ad Adunanza sale dal 2% al 12% e lo spazio occupato nella RAM aumenta progressivamente quasi come se scaricasse il file lì e non su hdd. Appena si interrompe il download torna tutto come prima, CPU, RAM, ed emule che riprende a funzionare normalmente.

Mi viene il dubbio che possa essere un settore dell’hard disk danneggiato, per cui magari i vari rallentamenti e freeze sono semplicemente fallimenti di scrittura.

p.s. Specifico che ho 5 hdd interni meccanici uniti a formare uno storage space con mirroring a 2 vie (file system ReFS), ma non credo c’entri la configurazione dato che non ho mai avuto problemi con altri file.


#7

Io non riesco ad interrompere il download, una volta che freeza o lo chiudo io da gestione attività oppure aspetto che crashi da solo… Sono 3 giorni che provo e continua a dare lo stesso problema, non riesco a risolvere :frowning:


#8

Anch’io non riesco ad interromperlo quando si freeza, devo aspettare che smetta di scaricare da solo. Ieri ho dovuto aspettare 6-7 ore.
Comunque a me non crasha, forse perché ho abbastanza ram e cpu per sopportare il carico (32GB, i7 8700k), boh…


#9

Io non so per quanto resti bloccato, di solito provo a lasciarlo andare (tipo stanotte) ma poi quando torno al computer solitamente eMule lo trovo chiuso…


#10

Per curiosità hai provato a guardare l’utilizzo della ram per emule in gestione attività? Nei momenti in cui si blocca sale progressivamente come nel mio caso?


#11

No, però domani ci guardo e ti dico (adesso sono fuori)


#12

Oggi pomeriggio stavo per rispondere poi ho avuto un altro impegno, quando sono tornato il mio mulo era in freeze. Ho dato un’occhiata al consumo di risorse in gestione attività e il mulo in sé non stava consumando tantissimo ma ero oltre l’80% di impiego totale della Ram.
Ho chiuso il browser e tutto quello che avevo in uso tranne il mulo e dopo qualche minuto ha ripreso a lavorare regolarmente.
Lo scoglio è quasi certamente il trasferimento in scrittura e lettura sul disco e come avete ipotizzato, anche se il disco è perfettamente funzionante o se comincia ad avere qualche acciacco.
Va anche detto, ad onor del vero, che l’aggiornamento del mulo è fermo e questa cosa forse comencia a farsi sentire, specialmente per chi la linee veloci.

Qualche prova la potete fare seguendo questi consigli e dicendoci se sono serviti a migliorare la situazione: Cosa fare se eMule si blocca (freeze)?


#13

Grazie, domani provo e ti dico! :slight_smile:


#14

Il mio mulo si blocca non appena l’utilizzo della RAM inizia a salire, quindi già dal 26% di impiego totale (ho 32gb). Sicuramente la chiusura di qualche applicazione non può incidere in questa situazione. Però forse potrebbe essere una soluzione per stream81 per evitare il crash, magari causato proprio dall’impiego eccessivo di RAM…

Riguardo alla pagina dei consigli, avevo già letto e provato tutto. Anche la spunta su “creare nuovi file .part come sparse” non è servita a molto, dato che il file che sto scaricando non è nuovo e l’intera dimensione o quasi era stata già allocata in precedenza.

Comunque se il freeze è capitato anche a te proprio adesso che ne parliamo mi viene da pensare che sia una cosa piuttosto frequente :face_with_raised_eyebrow:


#15

Ok, adesso è crashato anche a me, con l’impiego generale di ram solo al 34%, 1700 MB circa impiegati dal mulo. Non si tratta quindi di un problema di saturazione di ram. Qualche minuto prima avevo provato a chiudere tutte le applicazioni: servito a nulla :disappointed:
Per vedere se era corrotto il file part ho provato anche a copiarlo da un hdd all’altro: trasferimento effettuato alla massima velocità senza intoppi.


#16

Frequentissimo no ma non siete certo i primi

Ci sono senz’altro problemi di trasferimento dati nei protocolli utilizzati da windows sia da sia verso l’hard disk e probabilmente anche con il router, per via delle connessioni simultanee (affermazione mia non accertata) che il codice del mulo, in determinate condizioni, non riesce a reggere.
Questa è una delle ragioni, non l’ultima in ordine di importanza, che hanno spinto l’Aduteam (dopo nottate di discussioni anche accese) a decidere di passare a Torrent e provare a sviluppare un nostro client (Tsunami).

A parziale riprova posso dire che sul mio stesso pc (che è abbastanza vecchio) i problemi di blocchi li ho molto più spesso (per non dire sempre) quando uso Windows (ed Emule), mentre se uso linux Mint (e Amule ovviamente) con pari velocità, hardwere e files condivisi non ho blocchi evidenti e quando accadono normalmente sono causati da altri errori di Amule. Altro esempio, con torrent non ho mai riscontrato problemi neppure con windows.
Ultimo esempio, non ho neppure problemi con questa “misera” piastra https://wiki.odroid.com/odroid-c2/hardware/hardware che monta Ubuntu, che ha solo due giga di ram e hard disk esterno connesso tramite USB2.

Detto ciò, scoprire quale sia il problema reale è quasi impossibile ma, se avete voglia e tempo per fare le cavie :slight_smile: , si possono provare altre piccole modifiche e vedere se danno qualche risultato.

Postate le immagini delle vostre schermate

  • Opzioni > Aspetto
  • Opzioni > Connessione
  • Opzioni > Avanzate (con particolare su Connessioni TCP/IP) e scorrendo la lista su Upload Dinamico
  • Opzioni > Adunanza

Sul lato del vostro hardwere ci sono un sacco di cose che potrebbero influire, la prima che mi viene in mente è lo stato del vostro Hard disk, per lo stato di “vecchiaia e usura” che per esempio dalla sua capienza residua (è vuoto, è pieno al 50% , all’80%, 95…?)


#17

Come avevi detto, magari è semplicemente un software vecchio il cui sviluppo è stato ormai abbandonato da anni, di conseguenza i vari bug sono stati trascurati. Non sono così convinto che il problema sia proprio nella natura stessa di emule o della rete ed2k.

So già cosa vuoi dirmi sulle connessioni massime, ma non credo che il problema sia quello, visto che si verifica solo col file in questione (ne ho altri 300 in download) che ha appena 2 fonti e per il quale ho solo 13 richieste per la sessione di 1 giorno.

Beh vecchiaia è possibile (6-7 anni l’hdd più vecchio), anche se fino ad ora ha funzionato senza intoppi, lo spazio residuo non credo visto che avanzano 800 GB. Comunque io mi sto convincendo che il problema sia proprio di quel file .part più che degli hdd. Probabilmente se lo riscaricassi da zero risolverei tutto :sweat_smile:


#18

E’ una prova facile da fare e che varrebbe la pena provare, un file corrotto potrebbe causare problemi.

Per fare la prova spegni il mulo, crea una cartella “Temp sospesi” (o quello che vuoi) e taglia incolla in quella cartella tutti i file temporanei (Tipo file PART, MET E BAK) incriminati.

Poi riapri il mulo e il download dovrebbe ricrearni altri tre e ricominciare da capo.


#19

Il fatto è che il blocco non si presenta spesso, adesso per esempio è da un giorno che sta scaricando a velocità sostenute senza intoppi, e questa notte il file dovrebbe completarsi.
Magari posso provare poi a riscaricarlo, ma non so quanto questa prova dimostrerebbe…


#20

Mah…io fino a 5mbs di download su un portatile e con disco interno non ho mai avuto problemi anche con file enormi, magari può capitare con qualche file corrotto ma onestamente non mi è mai successo!!