Amuleweb crasha continuamente

Grazie @murra :smiley: stasera appena torno a casa inserisco quanto richiesto.
Nel frattempo comunico che la guida che ho seguito è quella qui vostra per ubuntu 17.04 ed ho eseguito dpkg dei pacchetti scaricati sempre fra quelli presenti nella guida (x64).
L’installazione è andata tutta OK … per questo non capisco cosa ci sia.
Mi trovo un po perso senza un’interfaccia grafica :sweat_smile: … colpa di troppi anni di win… :smirk: che mi hanno abituato male :joy:

Questa la guida che ho seguito
https://forum.adunanza.net/t/installazione-amule-adunanza-ubuntu-16-10-17-04-derivate/11300

Grazie per il momento :slight_smile:

edit: Dimenticavo…

Occhio a non fare confusione tra ip della lan interna e ip pubblico, son due cose diverse

si…si… grazie, conosco la differenza :wink:

Eccomi… posto quanto richiesto :slight_smile:

aMuleD SVN compiled with wxGTK2 v3.0.2 and Boost 1.58 (OS: Linux)

amuleweb SVN compiled with wxGTK2 v3.0.2 and Boost 1.58

[eMule] AppVersion=SVN Nick=http://www.aMule.org QueueSizePref=50 MaxUpload=0 MaxDownload=0 SlotAllocation=2 Port=4662 UDPPort=4672 UDPEnable=1 Address= Autoconnect=1 MaxSourcesPerFile=300 MaxConnections=500 MaxConnectionsPerFiveSeconds=20 RemoveDeadServer=1 DeadServerRetry=3 ServerKeepAliveTimeout=0 Reconnect=1 Scoresystem=1 Serverlist=0 AddServerListFromServer=0 AddServerListFromClient=0 SafeServerConnect=0 AutoConnectStaticOnly=0 UPnPEnabled=0 UPnPTCPPort=50000 SmartIdCheck=1 ConnectToKad=1 ConnectToED2K=1 TempDir=/home/server/.aMule/Temp IncomingDir=/home/server/.aMule/Incoming ICH=1 AICHTrust=0 CheckDiskspace=1 MinFreeDiskSpace=1 AddNewFilesPaused=0 PreviewPrio=0 ManualHighPrio=0 StartNextFile=0 StartNextFileSameCat=0 StartNextFileAlpha=0 FileBufferSizePref=16 DAPPref=1 UAPPref=1 AllocateFullFile=0 OSDirectory=/home/server/.aMule/ OnlineSignature=0 OnlineSignatureUpdate=5 EnableTrayIcon=0 MinToTray=0 ConfirmExit=1 StartupMinimized=0 3DDepth=10 ToolTipDelay=1 ShowOverhead=0 ShowInfoOnCatTabs=1 VerticalToolbar=0 GeoIPEnabled=1 VideoPlayer= StatGraphsInterval=3 statsInterval=30 DownloadCapacity=700 UploadCapacity=100 StatsAverageMinutes=5 VariousStatisticsMaxValue=100 SeeShare=2 FilterLanIPs=1 ParanoidFiltering=1 IPFilterAutoLoad=1 IPFilterURL= FilterLevel=127 IPFilterSystem=0 FilterMessages=1 FilterAllMessages=0 MessagesFromFriendsOnly=0 MessageFromValidSourcesOnly=1 FilterWordMessages=0 MessageFilter= ShowMessagesInLog=1 FilterComments=0 CommentFilter= ShareHiddenFiles=0 AutoSortDownloads=0 NewVersionCheck=0 AdvancedSpamFilter=1 MessageUseCaptchas=1 Language= SplitterbarPosition=75 YourHostname= DateTimeFormat=%A, %x, %X AllcatType=0 ShowAllNotCats=0 SmartIdState=0 DropSlowSources=0 KadNodesUrl=http://upd.emule-security.org/nodes.dat Ed2kServersUrl=http://upd.emule-security.org/server.met ShowRatesOnTitle=0 GeoLiteCountryUpdateUrl=http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz StatsServerName=Shorty's ED2K stats StatsServerURL=http://ed2k.shortypower.dyndns.org/?hash= [Browser] OpenPageInTab=1 CustomBrowserString= [Proxy] ProxyEnableProxy=0 ProxyType=0 ProxyName= ProxyPort=1080 ProxyEnablePassword=0 ProxyUser= ProxyPassword= [ExternalConnect] UseSrcSeeds=0 AcceptExternalConnections=1 ECAddress=127.0.0.1 ECPort=4712 ECPassword={password} UPnPECEnabled=0 ShowProgressBar=1 ShowPercent=1 UseSecIdent=1 IpFilterClients=1 IpFilterServers=1 TransmitOnlyUploadingClients=0 [WebServer] Enabled=1 Password={password} PasswordLow= Port=4711 WebUPnPTCPPort=50001 UPnPWebServerEnabled=0 UseGzip=1 UseLowRightsUser=0 PageRefreshTime=120 Template= Path=amuleweb [GUI] HideOnClose=0 [Razor_Preferences] FastED2KLinksHandler=1 [SkinGUIOptions] Skin= [Statistics] MaxClientVersions=0 [Obfuscation] IsClientCryptLayerSupported=1 IsCryptLayerRequested=1 IsClientCryptLayerRequired=0 CryptoPaddingLenght=254 CryptoKadUDPKey=********** [PowerManagement] PreventSleepWhileDownloading=0 [UserEvents] [UserEvents/DownloadCompleted] CoreEnabled=0 CoreCommand= GUIEnabled=0 GUICommand= [UserEvents/NewChatSession] CoreEnabled=0 CoreCommand= GUIEnabled=0 GUICommand= [UserEvents/OutOfDiskSpace] CoreEnabled=0 CoreCommand= GUIEnabled=0 GUICommand= [UserEvents/ErrorOnCompletion] CoreEnabled=0 CoreCommand= GUIEnabled=0 GUICommand= [HTTPDownload] URL_1=

Ps: ho dato un occhio e installato aMule-remote… ma non mi funziona selezionando anche tutte e tre le possibili versioni :frowning:

Apri un terminale e digita:

echo -n PASSWORD | md5sum
(al posto di “PASSWORD” scegli una password a tua scelta, non serve che sia particolarmente robusta…)

ti verrà fuori una stringa tipo 319f4d26e3c536b5dd871bb2c52e3178

copia la stringa, e inseriscila (senza spazi) dentro il file amule.conf in questi due posti:

  1. nella sezione [WebServer] che servirà per amuleweb (Password=319f4d26e3c536b5dd871bb2c52e3178)

  2. nella sezione [ExternalConnect] che servirà per amulegui (ECPassword=319f4d26e3c536b5dd871bb2c52e3178)

Questo perché amuled è pensato per avere una password per permettere connessioni.

Inoltre la voce ECAddress=127.0.0.1 non deve contenere valori (quindi cancella 127.0.0.1 di modo che diventi ECAddress=). Questo serve ad abilitare tutti gli indirizzi ip affinché si ocnnetttano al demone.

Ora dovrebbero andare entrambi. A questo punto, quando apri amuleweb o amulegui, inserisci l’ip della macchina con amule e la password in chiaro (nel mio esempio, “PASSWORD”)

Funzia tutto?

Eccomi, ho voluto testare per qlc giorno prima di rispondere:

Si…fatto

Fatto anche questo… ma identico problema.
Crash… Random…come prima.
Ma al momento solo amuleweb… smette di funzionare, il demone è attivo e funzionante.

Le modifiche al file amule.conf vanno fatte con il demone spento!

Per curiosità, amulegui invece funziona o crasha anche quello?

@murra : Si…si… certo… non ho impostato amule con partenza in automatico all’avvio di sistema. quindi ho spento il server e riavviato… controllato ugualmente che non ci fosse il servizio attivo… fatto le modifiche e avviato con amuled -f

e ripeto… all’inizio funziona… mi collego faccio le mie ricerche… controllo le statistiche… chiudo il browser. poi lo riapro dopo qlc ora… funziona per 30 sec e poi mi appare “Pagina non in linea”… devo ricollegarmi al server e rilanciare amuleweb.

No !
non sapendo dove scaricarlo ho preso quello su googleplay (installato su Tablet) … ma nelle impostazioni qualunque versione del demone scelga mi genera errore e mi dice che il servizio si è arrestato all’improvviso.

Se riesco stasera faccio degli screenshot… perchè non so più cosa fare :weary:

Grazie per la Disponibilità

Tranquillo piano piano cerchiamo di trovare il motivo.

Per quanto riguarda amule web, credo che il fatto che si lanci ma crashi dopo poco sia dovuto a un’instabilità da quando amule è passato dalle wx 2.8 alle 3.x che hanno dei noti problemi di instabilità, tanto che alcuni non riescono neanche a compilare il programma principale.

Prova per scrupolo a riportare il log cat $HOME/.aMule/logfile e vediamo se c’è qualche info interessante sui crash.

Un’altra strada sarebbe fare uno script che controlla se amuleweb è attivo e in caso contrario lo rilancia (anche se non è una solizione molto ortodossa).

Credo che otterremmo risultati migliori cercando di far funzionare amulegui.

Prova con questi:

Se il PC da cui vuoi controllare amule gira con windows questa è la versione che uso io e funziona https://www.adunanza.net/download/amule-gui/aMuleGUI[2.3.1].exe

Se non dovesse funzionare prova col più vecchio https://www.adunanza.net/download/amule-gui/amulegui[2.2.2].exe

O con il più recente https://www.adunanza.net/download/amule-gui/aMuleGUI2.4.0.exe

Se invece ci gira linux sudo apt install amule-utils-gui
NB: i link corretti sono qui: Amule AdunanzA - tutte le GUI e oltre

Se dovesse crashare anche amulegui, posta una screenshot dell’errore che compare, e alla riapertura di amule gui controlla sul log se c’è qualche segnalazione del crash.

Ehm…
Preferivo gestire il server da Tablet… perchè altrimenti ho MAC dimmi che ci sono versioni da scaricare :smiley:

p.s. Ma se il problema è la versione di Amule… non posso disinstallare l’attuale e mettere quella precedente ?

Il tablet è android o ipad?

Per mac amulegui te lo devi compilare, io non l’ho mai fatto, ma googlando si trovano le info, ad esempio: https://piccimario.wordpress.com/2008/02/25/amulegui-e-anche-amule-volendo-sotto-macosx/ (versione un po’ vecchiotta…) magari prova e dicci come va. Se poi riesci potresti anche scrivere i passaggi qui in un post, così redigiamo una guida :wink:

edit: prova a leggere qui se trovi qualcosa di utile Installazione aMule AdunanzA su Mac Osx e F.A.Q

(io purtroppo non ho un mac per provare a compilare)

Il tablet è android o ipad?

Android

Per mac amulegui te lo devi compilare…

Ecco… non l’ho mai fatto… ma se non c’è altra strada provo… non mi tiro indietro.

mi ci vorrà qlc giorno visto che il week non ci sono e oggi sono super impegnato a lavoro… appena ho nuove posto.
Grazie Ancora @murra

@Asmis quando torni… per android c’è questa ottima app, creata da uno sviluppatore italiano, che permette di controllare il demone con le funzioni principali (ricerca file, controllo file in download, ecc):


Ad oggi non la mantiene più (ma funziona tranquillamente) e comunque il codice è stato rilasciato, se qualcuno volesse metterci le mani è una buona base da cui continuare. Io la uso quotidianamente (non richiede amuleweb, essendo una sorta di amulegui ridotta).

Certo per un controllo più completo è meglio amulegui (anche di amuleweb). Se vuoi quando torni ci buttiamo sulla compilazione per mac (se passasse @mr_hyde ci darebbe una grossa mano, essendo lui il guru di amule adunanza per Mac).

Io purtroppo possiedo solo un vecchio Mac PowerPC G4, una carretta che sto cercando di resuscitare, ma ci gira al massimo Snow Leopard, anni luce di distanza dai sistemi operativi come Sierra.

Comunque vediamo che si può fare :wink:

Eccomi…
Scusate il ritardo, ma in questo periodo sono trattenuto di più sul lavoro :sweat:

@murra, si la prima volta ho scaricato proprio quella… ma a me non funziona ricevo sempre questo messaggio (allego screening)

Stamani mattina… visto che il mio gatto ha pensato bene di buttarmi giù presto (la domenica non esiste) mi sono collegato ad amuleweb e con altro dispositivo controllavo cosa succedeva collegandosi in Ssh… ed ho carpito questo messaggio:

Con una paginata di scritte per me incomprensibili (ho fatto screening) se serve.

Grazie e buona domenica a tutti

Amule remote va configurato: clicca in alto a sinistra (sui tre puntini), quindi impostazioni.

Inserisci l’indirizzo ip del pc con amule;
la porta remota (4712 se non l’hai cambiata è quella di default)
la tua password in chiaro
e la versione di amule (2.3.1 dovrebbe funzionare)

e via.


Per amule CMD, se posti il log aiuterebbe. Ma il problema, secondo me è che amule compilato con le wx 3.0+ ha dei problemi di instabilità (era già uscito il problema tempo fa…) e amuleweb non riesca a reggere, crashando. In tal caso o provi a installare una versione più vecchiotta o a compilare con le wx 2.8 che sono stabili.

1 Like

Avevo già provveduto.
Il messaggio mi esce con tutti i parametri settati e con qualsiasi versione di amule scelga :sob:

Ci sto in entrambi i casi.
Dove e reperisco i file par le installazioni?
Come si compila?
Sul pc è installato ubuntu server (Welcome to Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-87-generic x86_64))

Qui c’è la guida da seguire per la compilazione

http://wiki.amule.org/wiki/HowTo_get_aMule_web_interface

Qui le wx

https://wiki.wxpython.org/InstallingOnUbuntuOrDebian


Ma prima della compilazione, proverei a disinstallare completamente amule (apt remove --purge amule*) e reinstallarlo per bene.

Io ho la tua stessa versione di amuled, su un computer con ubuntu 16.04, uso amule remote senza alcun problema. Quindi la prima cosa che mi viene in mente è che qualcosa non è configurato correttamente… Hai il firewall su ubuntu server? Hai configurato iptables?

Forse la cosa migliore è che ci incontriamo in chat e cerchiamo passo passo di configurare tutto…

No e No … tutto libero. anche perchè attualmente sono nattato (poi richiedo ip pubblico).

se le parti met scaricate non le perdo… posso farlo anche subito (tradotto qlc giorno)… altrimenti attendo il completamento di un paio di files e poi procedo.

Utilizzo sempre i file che ho trovato nella guida precedentemente citata ?

:meme_fantastic:
ma non vorrei disturbare dato il periodo.
Intanto posso provare a disinstallare e installare nuovamente. ma la cosa strana è che non ho ricevuto nessun errore o scritta strana… anzi è andato tutto liscio (e da li dovevo preventivare “questo”… non ho dannato su una cosa e me la fa scontare in altro modo… :joy: )

1 Like

come preferisci, ma basta che ti salvi la cartella temp e poi la rimetti dopo la reinstallazione.

Nessun disturbo, ma il problema è che parto domani :smiley:

Ci si rivede a fine agosto se non hai fretta.

Comunque, ripeto, hai una installazione similissima alla mia, difficile che a me funzioni e a te no. Direi che ci sentiamo a fine agosto in chat e cerchiamo passo passo di installare tutto correttamente da 0 (molto più facile che compilare).

1 Like

Non sono scomparso… :joy::joy:

Ma adesso in Ferie… dovrei essere operativo tra una decina di giorni… se l’offerta è sempre valida :smiley:

1 Like

da quale guida?
se da riga di comando lanci il comando amuled dovresti avere una cosa simile, copia e incolla :wink:

dietpi@DietPi:~$ amuled
2017-08-31 17:37:30: Initialising aMuleD SVN compiled with wxBase(GTK2) v2.8.12 and Boost 1.64 (Snapshot: rev . 11170+)

con le ultime versioni svn (quelle di sviluppo) NON funziona l’app che ti ha consigliato @murra

inoltre anch’io sto avendo problemini di crash su amuled ma non ho capito ancora di cosa si tratta.

Questo argomento è stato automaticamente chiuso 90 giorni dopo l’ultima risposta. Non sono permesse altre risposte.