Amule dopo catalina 64 bit


#21

In realtà @mr_hyde ha aggiornato amule adunanza un paio di mesi fa, quindi potrebbe aggiornare ancora.

La versione di sviluppo è la moonriver, ma l’unica prova da fare sarebbe compilarsela da soli e vedere. Purtroppo al momento non ho un mac per testare.

Comunque secondo me aspettando, un po’ appena passa @mr_hyde si potranno avere aggiornamenti.


#22

Ops, non lo sapevo…
Non vedo @mr_hyde da un po’, non credevo avessere fatto qualcosina di recente :slight_smile:


#23

scusate oggi ho lanciato aggiornamento Mac Catalina e amule non va piu non trovo quello a 64 abit come si fa help. si sa se ci sara nuove versioni a sapere non aggiornavo porca paletta


#24

Di solito prima di postare si legge tutta la discussione,di solito …


#25

scusami non sono pratico dei forum appunto mi rivolgo a voi se sapete qualcosa ho letto varie discussioni quindi bisogna aspettare solo giusto?


#27

Trovata una versione di aule a 64 bit
Aggiornato a Catalina e funziona :+1:


#29

Rendi partecipe la community :wink:


#30

Letta così mi sembra una medicina,aulin 64mg
:rofl::rofl::rofl::rofl:


#31

Buongiorno, scusate la mia ignoranza, peraltro confessata più volte, ma mi è oscuro il significato di “ aule a 64 bit”

Potrei avere chiarito il concetto, grazie


#33

Non è aMule Adunanza… Posso mettere lo stesso il link per scaricarlo ?


#34

In effetti… :blush::rofl:


#35

Ho sbagliato… E’ aMule 64 bit e può essere usato con Catalina… Quello di adesso è 32bit


#36

Ciao a tutti e scusate per l’assenza…
Ho avuto un po’ di problemi in famiglia quest’anno che hanno complicato le cose.

Per aMule (normale) e aMule AdunanzA: sono sicuramente compilabili anche a 64 bit (e giurerei che su sourceforge di AdunanzA ci siano le versioni universal binary, ma ammetto che fino a poco fa non avevo un Mac con S.O. recente quindi non li ho mai provati dopo El Capitan).

Io per me compilo una versione di aMule di sviluppo, ma ha un po’ di problemi (principalmente layout sbagliato, qualche campo delle dimensioni errate e davvero inguardabile con il tema scuro di MacOS) a causa delle nuove wxWidgets (e usare le vecchie su Mac OS nuovi non è banale).

Vedrò di provare a ricompilare una versione per Catalina, occhio però che NON ho Mac/macchine virtuali con i SO da 10.12 a 10.14 compresi, quindi per quelli non posso provare (io al momento uso la beta di Catalina su un Mini 2018 e El Capitan su un mini 2009).

Non vi aspettate che mi riesca a farlo a breve (devo fare un po’ di aggiornamenti dei tool di sviluppo e trovare spazio disco :slight_smile: )

Ciao,
Mr Hyde


#37

Intanto sto installando una VM con Catilina per provare anche io. Vediamo se effettivamente ci sono problemi

L’aggiornamento da Mojave dura giorni :sob:


#38

Primo tentativo con “vecchie” wxWidgets 3.0.4, abbastanza inguardabile se usate il tema scuro…
amule (AdunanzA):
https://drive.google.com/file/d/1y0DfAdKhz4GA33UkiL_71ZBv3IDO0TRr/view?usp=sharing
amulegui (AdunanzA):
https://drive.google.com/file/d/1G0tcs6tPTxXXxNeQsHHJzQim-tiuc_GR/view?usp=sharing

Secondo tentativo con “un po’ più nuove” wxWidgets 3.1.2 (ma purtroppo alcuni controlli risultano con la dimensione sbagliata, ad esempio il campo dove “incollare” i link ed2k):
amule
https://drive.google.com/file/d/1u79I7z-3mj7W62DQCTgG84FKUTxvjY7v/view?usp=sharing
amulegui
https://drive.google.com/file/d/1_EGe0MrHw6j5AWOzGCUFoHhFpn26xtSO/view?usp=sharing

Poi ditemi se veramente questi link di google drive sono utilizzabili :slight_smile:


Amule adunanza per osx Catalina
#39

Ciao mr_hyde,

innanzitutto grazie. Sto facendo girare il tuo “secondo tentativo” e sembra funzionare. Unica cosa, e non so se è un problema della mia scarsa praticità, è che ora i link non li prende in automatico ma solo con copia e incolla.

Grazie ancora
Ciao


#40

Purtroppo Catalina va solo su APFS, che non è compatibile con Virtualbox… Niente VM per testare.

Aspettiamo un po di feedback dalla community e se gira tutto metto i link nella pagina dei download


#41

Io ho trovato questo…

Non è adunanza ma funziona su Catalina. Però è solo in inglese


#42

Vedi http://forum.amule.org/index.php?topic=21395.msg152065#msg152065

il problemino è ed2khelper che, nell’attuale pacchetto di aMuleAdunanzA (e aMule visto che usiamo lo stesso) è compilato per PPC e i386 ma non per x86_64, infatti:

MM2018:MacOS mrhyde$ pwd

/Users/mrhyde/AMULE2/x86_64/src/MoonRiver/aMuleAdunanzA.app/Contents/MacOS/ed2kHelperScript.app/Contents/MacOS

MM2018:MacOS mrhyde$ file applet 

applet: Mach-O universal binary with 2 architectures: [ppc:Mach-O executable ppc] [i386:Mach-O executable i386]

applet (for architecture ppc): Mach-O executable ppc

applet (for architecture i386): Mach-O executable i386

Ho generato un nuovo ed2kHelper.app (come suggerito nel post di aMUle che ho linkato) e ci farò qualche esperimento, se va tutto bene aggiorno i pacchetti.


#43

@mr_hyde testato per un po’ su catilina, il download procede senza intoppi

Bello anche il tema scuro!

Ci sono in effetti dei problemi di visualizzazione tra le schermate. Quando ho tempo posto più feedback.