Amule dopo catalina 64 bit

Grazie mille Hyde per il lavoro che stai svolgendo!
non riesco a far funzionare “ed2kHelperScript” qualcuno mi può aiutare? io sono Mojave e sto testando prima di installare Catalina. La versione di aMule Adunanza è la rev 599
Thanks

Un messaggio è stato fuso in un argomento esistente: Amule adunanza su ubuntu 16.10

Decisamente off-topic, mio suggerimento: apri una discussione apposta (o chiedi se ti possono spostare questo post) e descrivi i passi che hai fatto fino ad ora e dove ti sei fermato/hai avuto problemi.

Non è che non ho intenzione di aiutarti ma temo che, se c’è qualcuno di più esperto di me sui pacchetti Ubuntu, semplicemente possa non accorgersi della tua richiesta perché postata in una discussione che riguarda esplicitamente MacOS e non Ubuntu.

Per la sola compilazione ti posso aiutare, sul creare pacchetti su Ubuntu ahime’ non è il mio campo.
E’ anche possibile che esistano già repository con amuleadunanza SVN ma per questo meglio che ti rispondano altri.

Ciao,
Mr Hyde

1 Like

grazie, aprirò un topic apposito!

ti ho già spostao io nella sezione idonea :wink:

APERTO SOLO CON QUESTO aMule-2.3.2-macOS_10.14-wxWidgets-3.0.4.zip! CON CATALINA!

1 Like

Ciao mr_hyde! Grazie di cuore per il lavoro che trovi il tempo di svolgere operando peraltro a partire da una versione non stabile di Amule…
Sto testando la 599 da 10gg su Mojave prima di installare Catalina, e ho riscontrato un solo crash, in occasione di mancanza di spazio su disco, anziché bloccarsi e segnalare per ogni file spazio su disco insufficiente. la 599 ha semplicemente crashato.
Se vuoi ti mando il log del crash.
Osservazioni: l’app 599 occupa meno percentuale di CPU ed è più responsive. Difetti riscontrati:
uno banale - quando apri un menu contestuale su un singolo file nella sezione download, e selezioni un’opzione qualunque (tipo dai priorità alta o sposta tutti gli A4AF su questo file) la riga del file resta evidenziata in nero (ovviamente non uso dark mode su Mojave) e non si legge più. Rilasciando l’opzione tasto destro e ricliccando su, la riga perde evidenziazione e torna normale;
uno invece serio - il mulo lavora in background, ma tende a rallentare se non è in primo piano o se lo schermo va in stop. Lo tengo in primo piano ma non basta, appena riclicco nella finestra la velocità di download sale nettamente. Ma più serio ancora è il server attivo che va, come dire, in stop: nel senso che il download va avanti, ma se faccio una ricerca (globale) il server non risponde. Se clicco tasto ds sul server, l’opzione riconnetti al server funziona, mi riconnette e subito dopo rinnovo la ricerca e funziona tutto.

Ora di default faccio riconnetti al server prima di ogni nuova ricerca, ma l’impressione è di un server che funge con i file messi in download, non però con le ricerche, dopo un po’ che il mulo va avanti, a meno che tu non riconnetta.

Grazie comunque davvero di cuore, questa 599 è sufficiente per farmi pensare di passare a Catalina, salvo che tu non ne partorisca una partendo da una stabile…

Buon lavoro!

Mr Blue

2 Likes

Buonasera a tutti,
sono nuovo del forum ma ultimamente vi ho seguito in parecchie discussioni. Ho usato emule, poi amule e infine amule adunanza, circa 17 anni in totale. Anche io prima di passare a catalina volevo essere sicuro che con amule adunanza non ci fossero problemi.
Con la versione aMule-2.3.2-macOS_10.14-wxWidgets-3.0.4 tutto va bene, non ci sono crash e ed2k e kad si connettono. Ma è in inglese e tutta da riconfigurare per me, dato che negli ultimi 8 anni ho usato solo amule adunanza.
Con la versione aMuleAdunanzA-2016.1-rev599_min_10_11_Boost_OSXCocoa_wx313_x8664, al primo avvio va tutto bene, con connessione kad ed ed2k. Nel momento che chiudo amule e lo riapro, va subito in crash e non se ne parla di riaprirsi, fino a quando non riavvio il mac (se può servire ho il log completo che spiega cosa causa il crash, ma non so come allegarlo qui). Riavviando il mac, amule si apre e gira bene fino a quando non lo chiudo e successivamente cerco di riaprirlo.
Spero di essere stato chiaro e di avervi dato indicazioni che possono servire a rendere stabile la versione adunanza.
In questi giorni proverò a seguire le indicazioni di murra, partendo da un’installazione pulita per capire se c’è qualche file che si corrompe.
Mr Hyde, grazie mille per il tuo instancabile lavoro…

Certo allega il log che sicuramente aiuterà @mr_hyde a debuggare.

A come lo descrivi pare un problema sulla fase di chiusura. Magari rimane aperto qualche processo? Bisognerà indagare.

01 dal system log file.txt (3,6 KB)
02 log completo amule_2020-02-14-014907.txt (65,2 KB)

Si, ho confrontato le configurazioni di amule prima e dopo il crash, e non ci sono file corrotti. In allegato il log completo.
PS: neanche a me funziona ed2kHelperScript, non accoda i file

Aiuto!!! Possiedo un Mac Book Pro e da quando mi si é scaricato l’aggiornamento con catalina Amule adunanza non funziona più. Cosa faccio???

Mi chiedo se hai letto anche il topic visto che qua hai anche la soluzione al tuo problema…

Ciao, intanto un enorme grazie per lo splendido lavoro che stai facendo. Volevo solo segnalare dopo avere provato tutte le versioni che a partire dalla 586 con wx 3.1.3 fino all’ultima 599 l’anteprima dei file video o la loro visione non funziona più invece con l’ultima versione 586 wx 3.1.2 l’anteprima funziona correttamente. Spero puoi sistemare questa cosa perché la versione 599 è più stabile ma se non funziona l’anteprima serve meno. Grazie ancora.

3 Likes

Ciao a tutti e grazie per aver rilasciato una versione di aMule per chi ha aggiornato il Mac a Catalina! Volevo chiedere un piccolo favore, se possibile. Purtroppo, su OSX è attivo l’App Nap, che sarebbe uno strumento creato da Apple per il risparmio energetico. Alle app, quando sono ridotte a icona o si blocca lo schermo perché non si utilizza il Mac per diversi minuti (nel mio caso ho impostato che lo schermo si disattiva dopo 5 minuti di inattività), vengono tolte le risorse per farle entrare in modalità risparmio energetico e questo si traduce, nel caso di aMule, in una drastica riduzione della velocità di download. Prima, con la versione stabile di aMule per Mac bastava semplicemente cliccare con il tasto destro sull’app di aMule, fare clic su “Ottieni informazioni” e mettere la spunta su “Disabilita App Nap”. Purtroppo con questa versione di aMule non c’è questa opzione e non so per quale motivo. So solo che quando riduco a icona o lo schermo si spegne, aMule va lentissimo, mentre appena fai ripartire il Mac o apri aMule a schermo intero, i download si velocizzano subito! Purtroppo non c’è un modo per disabilitare App Nap in maniera definitiva. Ho provato a seguire qualche guida per disattivarlo ma non ha funzionato quindi non ci sono alternative! Grazie mille per tutto quello che fate! :smiley:

1 Like

Ragazzi buonasera a tutti! io sono nuovo del forum… vi ringrazio per il lavoro che fate.
Chiedo un aiuto: ho installato la versione 599 su IOS Catalina… funziona perfettamente tutto tranne il KAD… non vuole saperne di andare. Eppure le porte le ho settate… eD2k va perfettamente con ID alto… ma KAD nulla… la freccetta rimane gialla (a destra in alto gialla, a sinistra in basso verde).

1 Like

ciao @Biemme86 benvenuto! Oltre alle informazioni che si possono reperire in questo thread, prova a compilare il questionario postando le risposte QUI (dovrai aprire un nuovo post), giusto per escludere altri problemi oltre al OS.

Grazie! Ho fatto come mi hai detto, speriamo in un riscontro positivo!

Ciao a tutti, sono nuovo del forum; la versione 599 che funziona su IOS Catalina e’ quella che trovo qui?

Che voi sappiate, almeno la ricerca Global funziona, o va in crash periodicamente, o funziona abbastanza bene?
Grazie di tutto!

Ciao a tutti, prima di tutto grazie per quello che fate e poi …ma veramente ora esiste una versione a 64 del mulo compatibile con Catalina? Ditemi tutto vi prego :pray:

@fabmax
@Orrie
Download aMule AdunanzA per GNU/Linux e Mac OSX