aMule Adunanza su QNAP ARMv7 (TS231)

amule_adunanza

#41

la cartella /opt è un link (symlink) ad una cartella che decidete voi. Prima di installare Optware, vi consiglio di crearla (nel mio caso Optware-NG) all’interno di /share/CACHEDEV_DATA1/.qpkg/

Mi è parso di capire di fare così…


#42

vuol dire che la cartella “opt” (che hai già), va collegata ad una cartella che scegli tu e che crei in .qpkg

ora nulla toglie che la chiami ancora “opt”, ma poi genera confusione.

edit: ho modificato la frase della guida, così da evitare fraintendimenti


#43

Ok, quindi, se ho ben capito io creo la cartella opt “dove voglio”, poi creo una cartella pluto in /share/CACHEDEV1_DATA/.qpkg

Dopodichè faccio un softlink alla cartella dalla cartella /opt a /pluto ?

mkdir opt

cd /share/CACHEDEV1_DATA/.qpkg
mkdir pluto

ln -s /share/CACHEDEV1_DATA/.qpkg/pluto/opt


#44

[~] # cd / [/] # ls Apps/ hd_root_tmp@ new_root/ rpc/ usr@ bin/ home@ opt@ sbin/ var/ dev/ lib/ php.ini@ share/ etc/ mnt/ proc/ sys/ flashfs_tmp/ musicstation/ root/ tmp/ [/] #

Il softlink lo riconosci dalla “@” dopo il nome. E’ la stessa logica del “crea collegamento” di Windows, quindi non crei prima il collegamento (cartella opt) che andrai a fare dopo (softlink ad opt).

Creati la cartella pluto e poi dai semplicemente il comando che c’è nella guida:

ln -s /share/CACHEDEV1_DATA/.qpkg/pluto /opt

Aggiungo anche un esempio di come sarà dopo

cd / && ls -la

drwxr-xr-x    2 admin    administ        40 Jan  1  1970 new_root/
lrwxrwxrwx    1 admin    administ        38 Oct  2 13:31 opt -> /share/CACHEDEV1_DATA/.qpkg/Optware-NG/

Come vedi, la cartella “new_root” è segnata con uno slash dopo il nome, il collegamento, nonostante sia trattato come una cartella, in quanto punta alla cartelle Optware-NG, non ha lo slash finale e ha la freccia ad indicare, appunto, il link.


#45

Grazie alla pazienza enorme di @clsalva sono riuscito ad installare Optware-Ng, dopodichè ho seguito pedissequamente i comandi.
Ho creato la cartella autorun, ma come metto il file “autorun.sh” e dove si trova? Lo devo creare io? E nel caso, cosa deve riportare scritto il file?

Ehm… buonanotte e grazie di nuovo!


#46

Il contenuto è la parte di codice sotto quella parte di guida.
Per crearlo devi usare “nano” (l’hai installato col comando ipkg qualche riga sopra).

nano autorun.sh

Incolli il testo che c’è nella guida ed esci salvando.

Poi non ricordo se serve, fai un

chmod +775 autorun.sh

…e continua :slight_smile:
k.


#47

Questa? giusto per non incorrere in incomprensioni… :slight_smile:

[Autorun]
Name = Autorun
Status = complete
Version = 1.0
Author = Claudio Salvatore
Date = 2016-02-06
Shell = /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/autorun
Desktop = 1
Enable = TRUE

poi continuo con questo

#!/bin/sh

#cancello il refuso della cartella
rm -R /opt

#creo link virtuale ad Optware
ln -s /share/CACHEDEV1_DATA/.qpkg/Optware-NG /opt

e poi cambio la porta della connessione ssh da 22 ad un’altra.


#48

Devi seguire la guida!!!

Ho creato quindi la cartella “autorun” [/share/CACHEDEV1_DATA/.qpkg/autorun/] con all’interno il file autorun.sh

#!/bin/sh
#cancello il refuso della cartella
rm -R /opt

#creo link virtuale ad Optware
ln -s /share/CACHEDEV1_DATA/.qpkg/Optware-NG /opt

la parte che hai messo tu è 50 righe dopo! :joy: :joy: :joy:


#49

update settembre 2017

Aggiornato il package [Autorun] in qpkg.conf perchè con la nuova versione del sistema operativo (4.3) le vecchie istruzioni non erano più valide e riconosciute.


#50

ciao cisalva,

sto seguendo la tua guida per l’installazione di Adunanza dopo che il mio Qnap ha deciso di andare in vacanza successivamente all’installazione dell’ultimo aggiornamento firmware.

Ho installato Openssh, seguito la procedura indicata ma quando eseguo la prova con il comando indicato mi viene risposto
“Privilege separation user nobody does not exist”

l’utente amule l’ho creato, mi sto connettendo su SSH su un’altra porta (modificata come indicato nella guida), ma qualcosa mi manca e non ho idea di cosa sia…

Sto cercando in rete qualche riferimento all’errore e magari qualche soluzione allo stesso.

Qualche idea?


#51

Secondo me devi modificare il file di configurazione di Openssh. Mi sa che tenta di collegarsi di default con l’utente “nobody”…