Amule adunanza su nas buffalo. Non riesco a connettermi

amule_adunanza

#1

Versione aMule AdunanzA utilizzata: pacchetto amule-adunanza_3.14b3-9_arm.ipk
Risultato del test delle porte (si trova in aMule > Preferenze > Connessione > Verifica Porte): NA
Indirizzo IP rilevato dal Test Porte, SOLO i primi 3 numeri (es. 100.xx, 10.xx, 2.23x): 2.22
Sistema operativo: linux
Versione Sistema Operativo (digita nel Terminale uname -a e riporta qui il risultato): Linux LS-WVL9E3 3.3.4-88f6281 #7 Fri Mar 27 10:50:54 JST 2015 armv5tel unknown
Regole del Firewall (digita nel Terminale sudo iptables -L -v -n e copia qui il risultato): command not found
Tipo di connessione (es. adsl, fibra, aziendale, alice adsl, wi-fi o cavo): adsl fastweb
Marca e Modello dell’hag/router a cui sei collegato (es. Technicolor TG788vn): argo 55+
L’ indirizzo IP rilasciato dal router al PC (es. 192.168.1.129, 10.110.1.254): 192.168.1.130

Ciao a tutti.
Sto cercando di reinstallare amule adunanza sul mio buffalo LinkStation Pro Duo LS-WVL/R1.
Attaulmente il nas è connesso via cavo al router FW.
Ho verificato l’apertura delle porte collegando al posto del nas un pc con win7 utilizzando adunanza sulle stesse porte 4662 e 4672.
Installo il pacchetto amule-adunanza_3.14b3-9_arm.ipk e sembra tutto ok.
Provo ad aggiungere un utente diverso da root ma qui ho il primo problema: l’utente viene aggiunto ma putty mi fa entrare solo tramite root.
A questo punto lancio il comando amuled -f o amuled: stesso risultato.
Anche dopo diverso tempo collegandomi a IP:4711 ottengo connection status not connected e kad status disconnected.
Allego anche i file amule.conf e remote.conf opportunamente (spero!) modificati. Per non saper ne leggere ne scrivere cerco nel nas tutti i file amule.conf e remote.con e li sovrascrivo con i file seguenti.

[eMule]
AppVersion=2.2.2
Nick=molla
QueueSizePref=50
MaxUpload=50
MaxDownload=1000
SlotAllocation=2
Port=4662
UDPPort=4672
UDPDisable=0
Address=
Autoconnect=1
MaxSourcesPerFile=300
MaxConnections=500
MaxConnectionsPerFiveSeconds=20
FileReAsk=1558
SaveL=3358
PFlags=0
ShowStats=0
RemoveDeadServer=1
DeadServerRetry=3
ServerKeepAliveTimeout=0
Reconnect=1
Scoresystem=1
Serverlist=0
AddServerListFromServer=0
AddServerListFromClient=0
SafeServerConnect=0
AutoConnectStaticOnly=0
UPnPEnabled=0
UPnPTCPPort=50000
SmartIdCheck=1
ConnectToKad=1
ConnectToED2K=1
TempDir=/mnt/array1/Share/Amule/Temp
IncomingDir=/mnt/array1/Share/Amule/Incoming
ICH=1
AICHTrust=0
CheckDiskspace=1
MinFreeDiskSpace=1
AddNewFilesPaused=0
PreviewPrio=0
ManualHighPrio=0
FullChunkTransfers=1
StartNextFile=0
StartNextFileSameCat=0
FileBufferSizePref=16
DAPPref=1
UAPPref=1
AllocateFullFile=0
OSDirectory=/opt/share/amule/.amule
OnlineSignature=0
OnlineSignatureUpdate=5
EnableTrayIcon=0
MinToTray=0
ConfirmExit=1
StartupMinimized=0
3DDepth=10
ToolTipDelay=1
ShowOverhead=0
ShowInfoOnCatTabs=1
ShowRatesOnTitle=0
VerticalToolbar=0
ShowPartFileNumber=0
VideoPlayer=
VideoPreviewBackupped=1
StatGraphsInterval=3
statsInterval=30
DownloadCapacity=300
UploadCapacity=100
StatsAverageMinutes=5
VariousStatisticsMaxValue=100
SeeShare=2
FilterLanIPs=0
ParanoidFiltering=1
IPFilterAutoLoad=1
IPFilterURL=
FilterLevel=127
IPFilterSystem=0
FilterMessages=1
FilterAllMessages=0
MessagesFromFriendsOnly=0
MessageFromValidSourcesOnly=1
FilterWordMessages=0
MessageFilter=
FilterComments=0
CommentFilter=
ShareHiddenFiles=0
AutoSortDownloads=0
NewVersionCheck=1
Language=
SplitterbarPosition=75
YourHostname=
DateTimeFormat=%A, %x, %X
AllcatType=0
ShowAllNotCats=0
SmartIdState=0
DropSlowSources=0
KadNodesUrl=http://update.adunanza.net/amule/adu_nodes.dat
Ed2kServersUrl=http://update.adunanza.net/servers.met
[Browser]
DefaultBrowser=0
OpenPageInTab=1
CustomBrowserString=
[Proxy]
ProxyEnableProxy=0
ProxyType=0
ProxyName=
ProxyPort=1080
ProxyEnablePassword=0
ProxyUser=
ProxyPassword=
[ExternalConnect]
UseSrcSeeds=0
AcceptExternalConnections=1
ECAddress=
ECPort=4712
ECPassword=ef7628c92bff39c0b3532d36a617cf09
UPnPECEnabled=0
ShowProgressBar=1
ShowPercent=1
UseSecIdent=1
IpFilterClients=1
IpFilterServers=1
[WebServer]
Enabled=1
Password=ef7628c92bff39c0b3532d36a617cf09
PasswordLow=ef7628c92bff39c0b3532d36a617cf09
Port=4711
WebUPnPTCPPort=50001
UPnPWebServerEnabled=0
UseGzip=1
UseLowRightsUser=0
PageRefreshTime=120
Template=final
[Razor_Preferences]
FastED2KLinksHandler=1
[SkinGUIOptions]
UseSkinFiles=1
Skin=
[Statistics]
MaxClientVersions=0
TotalDownloadedBytes=91161464042
TotalUploadedBytes=145752720658
TotalAduDownloadedBytes=68038854514
TotalAduFDownloadedBytes=37695754776
TotalAduDDownloadedBytes=30343099738
TotalExtDownloadedBytes=6256700052
TotalAduUploadedBytes=110543419956
TotalAduFUploadedBytes=54672120236
TotalAduDUploadedBytes=55871299720
TotalExtUploadedBytes=12731047512
[Obfuscation]
IsClientCryptLayerSupported=1
IsCryptLayerRequested=1
IsClientCryptLayerRequired=0
CryptoPaddingLenght=254
CryptoKadUDPKey=2091952271
[UserEvents]
[UserEvents/DownloadCompleted]
CoreEnabled=0
CoreCommand=
GUIEnabled=0
GUICommand=
[UserEvents/NewChatSession]
CoreEnabled=0
CoreCommand=
GUIEnabled=0
GUICommand=
[UserEvents/OutOfDiskSpace]
CoreEnabled=0
CoreCommand=
GUIEnabled=0
GUICommand=
[UserEvents/ErrorOnCompletion]
CoreEnabled=0
CoreCommand=
GUIEnabled=0
GUICommand=
[AdunanzA]
UseCustomIRCProgram=0
CustomIRCProgram=xchat
CustomIRCProgramFlags=–url irc://chat.adunanza.net:6667/#La_Stalla

Locale=
[EC]
Host=localhost
Port=4712
Password=ef7628c92bff39c0b3532d36a617cf09
[Webserver]
Port=4711
UPnPWebServerEnabled=0
UPnPTCPPort=50001
Template=php-default
UseGzip=0
AllowGuest=0
AdminPassword=ef7628c92bff39c0b3532d36a617cf09
GuestPassword=ef7628c92bff39c0b3532d36a617cf09

Cosa sto sbagliando?
Help me please!!!

C


#2

prova ad usare amulegui

OT @jdm mi vendicherò…


#3

Se non erro, mi serve l’applicazione.
Dove posso trovarla?
Per accedere al nas tramite putty sto utilizzando un laptop connesso tramite wifi al router.

Grazie.
Cristian


#4

Potresti essere più specifico?
Aprire amule tramite browser con IP:4711 non dovrebbe avere lo stesso risultato?

Un’altra domanda: quali file di configurazione devo andare a modificare? esattamente in quali directory si trovano?


#5

si, ma con la GUI hai il pieno controllo del demone di amule, con il browser ti mancano delle opzioni

nessuno, i tuoi file già permettono il collegamento con amuleGUI
la puoi scaricare da qua


#6

Ciao avevo scritto una guida qui per una vecchia versione, prova a vedere se corrispondono i passaggi Guida: Amule Adunanza sui NAS Buffalo


#7

Per l’ssh dovresti modificare il file di configurazione ssh per permettere l’accesso anche non root. Si dovrebbe trovare qui: /etc/ssh/sshd_config (dipende dalle varie distribuzioni)
modifica i parametri come ti servono

AllowUsers user1 user2 user3

@coge quella gui è per la versione 2.3.1, @cristian usa invece quello postato nella guida


#8

Innanzitutto grazie a tutti per il prezioso aiuto.
Utilizzando il file di murra, mi fa accedere con amulegui utilizzando uno user precedentemente inserito, ma con il quale putty non mi faceva accedere.
In ogni caso la guida credo di averla seguita step-by-step.
In ogni caso ho avviato amuled -f con l’utente root.
Ho avviato amulegui con utente diverso da root.
Per ora ho la seguente situazione:

Altri suggerimenti/ consigli?
Come mi connetto alla eD2k?

Thx
C


#9

In effetti non ho nemmeno un nodo nella lista.
Il link utilizzato è http://update.adunanza.net/amule/adu_nodes.dat

Devo aprire anche la porta 4665: ho trovato nelle opzioni di connessione la seguente nota:


#10

no

collegati ad un server e metti a scaricare un po di file,
i nodi dovrebbero aumentare lentamente fin quando nn ti ritroverai connesso


#11

Dove posso trovare la lista dei server utilizzabili?


#12

Ho inserito nella server list di amulegui il seguente indirizzo
http://update.adunanza.net/servers.met
Senza risultati.
Alternative?


#13

bastava usare il “cerca”…

ecco una delle discussioni in cui si parla di “lista server”

http://forum.adunanza.net/t/nessun-server-su-mac-snow-o-leopard-10-6-8-fw-100-10/7069


#14

Abbi pazienza, ma sono giorni che leggo e rileggo guide.
Nella gui avevo gia imposato l’indirizzo per i server, ma nulla


Ho anche provato ad usare il link ed2k, nulla.
Mi viene il dubbio che le porte non siano correttamente aperte: come posso verificarlo?
Amule è sul nas


#15

E il nas avrà il suo ip interno 192.168.1.xxx presumo per cui ti basta inserire le porte corrispondenti a quell’ip su amule e aprirle sull’hag tramite questa guida
Come aprire le porte di un hag/router sulla MyFastPage


#16

Grazie per il consiglio, ma il risultato è sempre lo stesso.
Sia kad che ed2k sono disconnected.

Ho installato emule adunanza sul pc dal quale faccio partire amulegui: si connette con successo.

Credo ci sia qualche problema di installazione del pacchetto sul NAS.

Qualche suggerimento per verificare se tutto è OK?

Grazie


#17

Rettifico.
Il pc che prima si connetteva ora è firewalled.
Questo è accaduto quando mi sono disconnesso e riconnesso, niente altro.
Mah…


#18

secondo me hai fatto qualche errore nell’installazione. Prova a purgare tutto e rifarla seguendo la guida.


#19

senza fare assolutamente nulla stamattina mi trovo magicamente connesso alla ed2k con id alto.
Nessuna connessione alla kadu: parchè?
Può essere un problema relativo al file nodes.dat?

Come faccio a far partire automaticamente il demone di amule automaticamente, senza usare crontab?

Grazie.
Cristian


#20

lo puoi far partire al boot come servizio