Adunanza su lnx Mint 20

Ciao murra. Ho seguito la guida per installare Adunanza su lnx Mint 20. Tutto liscio fino alla scompattazione del pacchetto .zip. L’installazione fallisce per un problema di dipendenze (install -f non risolve, e propone di rimuovere del tutto Adunanza).
Hai qualche dritta? Grazie!!

Ti incollo di seguito:


Estrazione di amule-adunanza (2012.1+2.3.1~dfsg1-0ubuntu3) su (2012.1+2.3.1~dfsg1-0ubuntu3)... Preparativi per estrarre libcrypto++9v5_5.6.1-8_amd64.deb... Estrazione di libcrypto++9v5 (5.6.1-8) su (5.6.1-8)... dpkg: problemi con le pre-dipendenze di libpng12-0_1.2.51-0ubuntu3_amd64.deb contenente libpng12-0:amd64: libpng12-0 pre-dipende da multiarch-support multiarch-support non è installato.

dpkg: errore nell’elaborare l’archivio libpng12-0_1.2.51-0ubuntu3_amd64.deb (–install):
problema con le pre-dipendenze - libpng12-0:amd64 non viene installato
dpkg: problemi con le pre-dipendenze di libupnp6_1.6.19+git20141001-1_amd64.deb contenente libupnp6:
libupnp6 pre-dipende da multiarch-support
multiarch-support non è installato.

dpkg: errore nell’elaborare l’archivio libupnp6_1.6.19+git20141001-1_amd64.deb (–install):
problema con le pre-dipendenze - libupnp6 non viene installato
Preparativi per estrarre libwxbase2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb…
Estrazione di libwxbase2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2) su (2.8.12.1+dfsg2-2ubuntu2)…
Preparativi per estrarre libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb…
Estrazione di libwxgtk2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2) su (2.8.12.1+dfsg2-2ubuntu2)…
dpkg: problemi con le dipendenze impediscono la configurazione di amule-adunanza:
amule-adunanza dipende da libupnp6 (>= 1:1.6.13); tuttavia:
Il pacchetto libupnp6 non è installato.

dpkg: errore nell’elaborare il pacchetto amule-adunanza (–install):
problemi con le dipendenze - lasciato non configurato
Configurazione di libcrypto++9v5 (5.6.1-8)…
Configurazione di libwxbase2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2)…
dpkg: problemi con le dipendenze impediscono la configurazione di libwxgtk2.8-0:amd64:
libwxgtk2.8-0:amd64 dipende da libpng12-0 (>= 1.2.13-4); tuttavia:
Il pacchetto libpng12-0 non è installato.

dpkg: errore nell’elaborare il pacchetto libwxgtk2.8-0:amd64 (–install):
problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per man-db (2.9.1-1)…
Elaborazione dei trigger per gnome-menus (3.36.0-1ubuntu1)…
Elaborazione dei trigger per desktop-file-utils (0.24+linuxmint1)…
Elaborazione dei trigger per mime-support (3.64ubuntu1)…
Elaborazione dei trigger per libc-bin (2.31-0ubuntu9)…
Si sono verificati degli errori nell’elaborazione:
libpng12-0_1.2.51-0ubuntu3_amd64.deb
libupnp6_1.6.19+git20141001-1_amd64.deb
amule-adunanza
libwxgtk2.8-0:amd64

Ciao @Francio71, stai seguendo una guida per una vecchia versione. Tu hai Mint 20 che è basata su Ubuntu 20 di recente uscita, quindi non abbiamo ancora una guida che funziona.

Direi che arrivati a questo punto il modo migliore è aspettare il repo aggiornato di @betsbass basato sulle recenti compilazioni di @mr_hyde.

Aspettiamo che passino di qui.

1 Like

OK. Io intanto l’ho installato, scaricandomi a mano le varie dipendenze da pkgs.org, via via che mi dava errore… non è stata una soluzione elegante dal punto di vista informatico, ma ha funzionato…
Intanto aspettiamo una soluzione come si deve. Ciao!

1 Like

:sunglasses: sono felice di vedere che c’è ancora qualche pinguino che vaga per le lande quasi deserte di adunanza,mi ricordo anni fà quando dopo l’uscita di CGA e SONNE,rimasi quasi l’unico a predicare il verbo di linux … :+1: :grinning:

4 Likes

:grinning: :+1: Sempre avanti!

2 Likes

Anche io semper fidelis

2 Likes

Domenica, all’ennesimo tentativo, sono riuscito ad installare Mint 20 Cinnamon. Non ci riuscivo perchè continava a chiedermi la partizione EFI per il boot che evidentemente non c’è e non sono stato capace di crearla.
Siccome sono un ignorante di alto grado, ho fatto come avevo fatto, per errore, quando mesi fa ho installato Ubuntu (tolto subito perchè ogni tanto mi freezava tutto) e dove avevo avuto gli stessi problemi di installazione:
Ho installato Mint ignorando ogni avviso riguardo i problemi che avrei avuto al boot poi, sempre tramite la chiavetta di Mint usata per l’installazione, ho ricreato il grub.
Infine sul nuovo Mint 20 ho installato Grub Customizer e ho riordinato il grub a mio piacimento.

Passando alla installazione di Amule Adunanza, io controllo e mi affido sempre come prima scelta all’ottimo lavoro di @betsbass che ringrazio sempre.
Ho installato la sua repository https://launchpad.net/~betsbass/+archive/ubuntu/unstable dove ho visto che ha creato la versione per Focal il 2 Maggio scorso e sono andato via liscio :old_birra:

sudo add-apt-repository ppa:betsbass/unstable
sudo apt-get update
sudo apt-get install amule-adunanza
3 Likes

Appena provato, e funzionante, su una installazione di Mint20 nuova di zecca.
Grazie!

1 Like

ciao goku,qui spiega più o meno tutto ma io uso questo sistema se non c’è altro sull’hd,lascio fare tutto a lui e si crea anche la partizione efi …
https://wiki.ubuntu-it.org/AmministrazioneSistema/Uefi
purtroppo non ho più fastweb se no avrei provato volentieri amule adu :sunglasses:

2 Likes

Io sul mio computer ho smanettato sulla partizione efi e ho messo refind, che praticamente è un bootmanager creato per i mac e che permette di scegliere cosa avviare quando si accende il sistema. Se hai bisogno chiedi pure @goku :wink:

1 Like